Centos 5.x and Webapp Xojo

HI all.

I’m locked on a problem of development with Xojo and Centos 5.X
I explain :

Before developing my application under Xojo webapp, i used a Xojo test from your website.
I’ve an idea to encode my application for a kind of server under Centos 5.9 or 5.10,
Unfortunately, these server cannot be updated to Centos 6.x and must stay on their original version.
I tried under Centos 6.0, and the cgi file works fine.
I tried under Centos 5.x, and there’s a problem with glibc 2.7. Sure, because, this version is exclusively included from Centos 6.0.

I don’t want to try to update this library because i don’t know what could happened after these update for the other apllications. :confused:

Do you know if a way exists for be able to launching any Xojo webapp under Centos 5.x (Glibc 2.5 here). ?
Perhaps a way to install Glibc 2.7 and keeping Glibc 2.5 (just an idea like that).

Thanks in advance for your help.


Not sure if this is any help, but the accepted answer suggests that multiple versions can run side by side -

Stack Overflow - multiple versions of glibc

EDIT - ah, but this one suggests that 2.7 won’t run on centos 5. - Maybe not …

Hm ok thanks a lot.

It’s too dangerous so… Like i thought so. :confused:
I’m very sad that Xojo didn’t use a such library compatible with Centos 5.6 and at least up to 5.10.

Best regards


Earlier versions of Xojo ran fine on CentOS 5.x. That’s where XojoCloud started. This change only came recently if I recall. Have you tried 2014r1?


It could be a good news, however today, i’ve not a web licence for the moment, I tried to make some tests before buy this one or any licence Web, or even Pro why not. Because i will need to use SQLite Database, and MySQL Database.

Yes i’ve Xojo 2014 r1 under desktop licence only (Linux, Windows, IOS) that’s all. :wink:

Forcing the version Glibc 2.7 seems to be a bad way !

Why Xojo could not be able to give some choice for the library to be used?
I would say that all new developments could not be longer compatible with Centos 5.x ?
It’s a little bit dangerous. :confused:


The last version of Xojo to support CentOS 5.x was Xojo 2013r3.3. CentOS 6 was required starting with Xojo 2013r4.

I will PM you download links to 2013r3.3.


I bought Xojo update to the Pro version…
So i could try to use the old version to be compatible with Centos 5.x
I’ll let you know.

It’s good.

I installed Xojo 2013r33 (Thanks at Paul for that), and i can compile my project for Centos 5.10

Thanks at all. :slight_smile: