Catalina and Console Apps

I have a console app that is part of a lightroom plugin. The app is code signed using

xattr -rc PATH


codesign --force --options runtime --deep ....

Lightroom plugins are a folder/package and this console app resides in a subfolder.
A simple zip of the folder has been fine up until now as Catalina does not accept it.

I sent the zip for notarization, which worked but was unable to get the stapler to attach to anything.

I then put it in dropDMG and could only use the developer certificates and not the installer ones. Either way, I could notarize it ok but Catalina still said the console app was untrusted.

I then put it in a pkg file and attached the mac installer certificate and notarized and it installed ok.

I also tried the above with just the console app, with no luck.

Surely there is a simpler way to get console apps onto Catalina?

I have run into the same issue…



I am still considering options.

Luckily I can setup the installer to actually install to a specific lightroom friendly location, but getting the user to choose a location does not seem possible.

None that I’m aware of; I have several customers who’re facing similar problems and I’ve not been able to get a viable solution from any of my contacts at Apple, apart from including it inside an application bundle.

However if your console application has a “Resources” folder, you can’t code sign the container application. Instead you must convert that console application into a Framework bundle. I’ve filed a bug report, but don’t have any hopes of it getting resolved.

If you’re wrapping your console application in a container application, you could use that as an installer and install it almost anywhere. Although I’ll admit I don’t know if the new security will permit you to install it /Applications.