Can't save project as text (for use with Git)

Firstly I must say I had a hard drive crash (resulting from very bad fragmentation of the drive). I had to erase the drive, reinstall El Capitan, and restore my files from a Time Machine Backup.

Every project I have is saved as Text (as set in Xojo Preferences), so that I can use Git. I open a Text project, but when it comes to saving it it wants to save it in Binary. Has anyone struck this before, and have a possible solution.

It may be your license.
A single-platform desktop license cannot save in source control formats.

See the chart here: https://www.xojo.com/store/index.php

Cliff: re-enable your license by going to Xojo web server (your account).

Xojo used anti-piracy system does not allows you to enable a machine (computer), but a hard disk. WEIRD !

So, if you bave enabled your computer and boot on an external hard disk… you cannot use the optional saves, cannot build, until you enable that HARD DISK. But when you boot on your internal HD, your troubles comes back…