Can't remote debug a web application.

I am trying to remotely debug a web app.
I have the remote debugger desktop on the host machine configured and locally.
However I get an error message on the console of the remote machine.
The IDE just sits there hung.

[quote]2014-01-28 1:25:44.441 PM Remote Debugger Desktop[14849]: 1:25:44 PM: StubLocator Error: 105
2014-01-28 1:25:44.442 PM Remote Debugger Desktop[14849]: 1:25:44 PM: StubLocator Error: 105
2014-01-28 1:25:44.442 PM Remote Debugger Desktop[14849]: 1:25:44 PM: StubLocator Error: 106
2014-01-28 1:25:44.442 PM Remote Debugger Desktop[14849]: 1:25:44 PM: StubLocator Error: 106
2014-01-28 1:25:44.442 PM Remote Debugger Desktop[14849]: 1:25:44 PM: StubLocator Error: 106
2014-01-28 1:25:44.445 PM Remote Debugger Desktop[14849]: 1:25:44 PM: StubLocator Error: 105
2014-01-28 1:25:44.445 PM Remote Debugger Desktop[14849]: 1:25:44 PM: StubLocator Error: 105
2014-01-28 1:25:44.445 PM Remote Debugger Desktop[14849]: 1:25:44 PM: StubLocator Error: 106
2014-01-28 1:25:44.445 PM Remote Debugger Desktop[14849]: 1:25:44 PM: StubLocator Error: 106
2014-01-28 1:25:44.445 PM Remote Debugger Desktop[14849]: 1:25:44 PM: StubLocator Error: 106
2014-01-28 1:26:14.599 PM Remote Debugger Desktop[14849]: 1:26:14 PM: Connection established
2014-01-28 1:26:14.600 PM Remote Debugger Desktop[14849]: 1:26:14 PM: Stub<-IDE HELLO, 13.4.1a0, Protocol: 6, Local IP: 139.48.44.34
2014-01-28 1:26:14.600 PM Remote Debugger Desktop[14849]: 1:26:14 PM: Using protocol version 6
2014-01-28 1:26:14.600 PM Remote Debugger Desktop[14849]: 1:26:14 PM: IDE Version supported
2014-01-28 1:26:14.600 PM Remote Debugger Desktop[14849]: 1:26:14 PM: Stub->IDE OLLEH, 1.9.021, 6, Remote Address: 139.48.44.188
2014-01-28 1:26:14.800 PM Remote Debugger Desktop[14849]: 1:26:14 PM: Stub<-IDE PLATFORM-REQUEST
2014-01-28 1:26:14.800 PM Remote Debugger Desktop[14849]: 1:26:14 PM: Stub->IDE PLATFORM-RESPONSE, Macintosh, x86, Mach-O10.8.5
2014-01-28 1:26:21.423 PM Remote Debugger Desktop[14849]: 1:26:21 PM: Stub<-IDE CREATEFILE, DeIdentificationWebApp.debug.tar.gz, Relative path: True,
2014-01-28 1:26:21.424 PM Remote Debugger Desktop[14849]: 1:26:21 PM: Stub->IDE CHALLENGE, 123EBF 139.48.44.34 139.48.44.188
2014-01-28 1:26:21.424 PM Remote Debugger Desktop[14849]: 1:26:21 PM: Waiting for RESPONSE
2014-01-28 1:26:21.455 PM Remote Debugger Desktop[14849]: 1:26:21 PM: Got a RESPONSE packet, about to decrypt
2014-01-28 1:26:21.455 PM Remote Debugger Desktop[14849]: 1:26:21 PM: Stub<-IDE RESPONSE, 123EC0 139.48.44.188 139.48.44.34
2014-01-28 1:26:21.455 PM Remote Debugger Desktop[14849]: 1:26:21 PM: Response accepted
2014-01-28 1:26:21.455 PM Remote Debugger Desktop[14849]: 1:26:21 PM: Creating file: BOOT:Users:deidentify:Desktop:DeIdentificationWebApp.debug.tar.gz
2014-01-28 1:26:21.456 PM Remote Debugger Desktop[14849]: 1:26:21 PM: Created the file list
2014-01-28 1:26:21.456 PM Remote Debugger Desktop[14849]: 1:26:21 PM: Added the file or folder to the file list
2014-01-28 1:26:21.456 PM Remote Debugger Desktop[14849]: 1:26:21 PM: Stub->IDE FILECREATION, File ID: 0, Status: 0
2014-01-28 1:26:21.489 PM Remote Debugger Desktop[14849]: 1:26:21 PM: Stub<-IDE FILEINFO, File ID: 0, Size: 5.423977e+6, Compressed: False, Stub Delete: False
2014-01-28 1:26:21.737 PM Remote Debugger Desktop[14849]: 1:26:21 PM: Stub<-IDE FILEPART, File ID: 0
2014-01-28 1:26:21.903 PM Remote Debugger Desktop[14849]: 1:26:21 PM: Stub<-IDE FILEPART, File ID: 0
2014-01-28 1:26:22.038 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Stub<-IDE FILEPART, File ID: 0
2014-01-28 1:26:22.096 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Stub<-IDE FILEPART, File ID: 0
2014-01-28 1:26:22.231 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Stub<-IDE FILEPART, File ID: 0
2014-01-28 1:26:22.344 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Stub<-IDE FILEPART, File ID: 0
2014-01-28 1:26:22.374 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Stub<-IDE FILEPART, File ID: 0
2014-01-28 1:26:22.374 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Stub->IDE FILEWRITTEN, File ID: 0, Status: 0
2014-01-28 1:26:22.491 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Stub<-IDE FILELAUNCH, File ID: 0, Launch in Terminal: False, Command line args:
2014-01-28 1:26:22.492 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Stub->IDE CHALLENGE, 123EC1 139.48.44.34 139.48.44.188
2014-01-28 1:26:22.520 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Got a RESPONSE packet, about to decrypt
2014-01-28 1:26:22.520 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Stub<-IDE RESPONSE, 123EC2 139.48.44.188 139.48.44.34
2014-01-28 1:26:22.520 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Response accepted
2014-01-28 1:26:22.520 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Decompressing DeIdentificationWebApp.debug.tar.gz
2014-01-28 1:26:22.646 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Untarring DeIdentificationWebApp.debug.tar
2014-01-28 1:26:22.926 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Launching DeIdentificationWebApp.debug.tar.gz
2014-01-28 1:26:22.926 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Could not launch DeIdentificationWebApp.debug.tar.gz
2014-01-28 1:26:22.926 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Stub->IDE SOS, Could not launch the file: 101
2014-01-28 1:26:22.959 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Stub<-IDE SEEYA
2014-01-28 1:26:22.959 PM Remote Debugger Desktop[14849]: 1:26:22 PM: Connection closed
[/quote]

You’re right - remote debugging a web app isn’t going to work
It’s not possible at this point

It used to be.

whats going on - I posted a message - it displayed twice - deleted one of them and they both deleted!

Is this a standalone app ?
Thats the only ones you can expect to be able to remove debug
But it looks like the app isn;t being unpacked based on the log you posted

Yes not a cgi.

Hmmm …… not unpacking which is odd
The stub is on Macintosh Mach-O10.8.5 ?
Whats the source machine ?
One option might be to NOT have the stub try & unpack it and you can manually unpack it & execute it using a cmd line

The development machine is:
mac 10.9.1
Xojo 2013 rel 4.1

The ‘web server machine’ is 10.8.5
running the Remote Desktop Debugger from 2013 rel 4.1

How do achieve what you are suggesting?

Has the remote machine go a user logged in where you can see its copy of the remote debugger stub running ?
Uncheck the “launch executable after receiving” item in the remote debuggers stub UI on that machine.
Then when the IDE sends the app it will be sent but NOT unpacked or started
Do that manually & start the app

Just to be clear. The remote machine and the development machine are side by side in the same office at the same desk.
Two different monitors, keyboards, mice and machines.
I am the logged in user on both machines.
I will try what you suggest… but do you think the debugger will connect to the downloaded program after I launch it?

[quote=61928:@Brian O’Brien]Just to be clear. The remote machine and the development machine are side by side in the same office at the same desk.
Two different monitors, keyboards, mice and machines.
I am the logged in user on both machines.
I will try what you suggest… but do you think the debugger will connect to the downloaded program after I launch it?[/quote]

Yes since its actually the debug app that connects back to the IDE as long as the IDE is still sitting there waiting for it to connect (which it should be)