Can't open a serial port in XP with Xojo 2014r2.1 program

I have been trying without success to update a data logging program on a client’s XP machine. The original was written in RB2012r2.1and I have tried both Xojo 2013r4.3 (which is supposed to support XPSP2) and 2014r2.1. As soon as Serial.Open is encountered while running, an UnsupportedFormatException is thrown. The same code executes properly on a Windows 7 machine. I can work around this by updating the original program in RB instead of Xojo and I will not be filing a feedback report. Perhaps I have saved someone some debugging trouble by knowing about this.

Oops. I am using 2014r2, not r2.1 beta

And does it work in the beta?

Its not working with anything right now. I have not tried the beta. I copied and pasted the program back into 2012r2.1 and it fails at the same place. I’m remote desktopping into it and thinking something has happened to the serial port that rebooting didn’t fix. May need to power it down to get it to work.

Could it be that the device is offline or the serial port is in use by another app?