Cant modify saved projects

Right now I try to test Xojo for Windows Desktop for educational purpose. I haven´t bought a license yet. When I save the project (i DONT create a standalone programm, I just save the project as binary) and reload it later, I am not able to modify it anymore. Is this a “special feature” or an intended feature?

Thanks in advance!

You can definitely modify saved binary projects with an unlicensed version of Xojo. Are you sure the project file is not marked as read-only or perhaps in a folder or device that is read-only?

What version of Windows ?
Where did you save the project ?

Thanks for your quick answers.
Windows-Version is Windows 7.
I saved the project in a Samba-Server. I CAN open the saved file, but when I try to add buttons etc. in the default window (in which I already could and did put buttons in before I saved the project) I can´t do so anymore.

I don´t even know how I could mark the project as read-only… I surely didn´t mark the file as only readable.

Some more information:

I´m a teacher and would like to introduce xojo (which I know as former Realbasic) to my students.

I am not really happy with Virtualbasic which is in my point of view just like VisualC++ with another syntax and hasn´t really understood the concept of Basic:
Providing a language for beginners and allowing to build a programm “on the fly” (without preparing by including hundreds of libraries) by simultanously allowing advanced users to take advantage of the opportunities of an object-oriented language.

I also like, that xojo ONLY shows the code which is relevant for the choosen class or even only the choosen event/methods - which once again stresses the object-oriented aspect and I really dislike Virtualbasic for not doing so and even showing me code which is automaticly generated and which I am not supposed to edit. Have they ever had a look at Realbasic, which was already implemented some hundert years ago?

Anyway, thanks in keeping Realbasic alive!

That could be the origin of your issue. This forum is full of accounts of issues with cloud drives. You may want to work on the local drive instead and see if the problem goes away.

Usually, it is better to work local, and save the file on a cloud or remote server only when the work is finished.

Thanks Michel,

I tried to save, load and edit on a local server and had no issues anymore.

Anyways, I played arround with the samba server some more and found out:

  1. I create a new project and fill out the field “application name” in the popping up window and move some buttons in window1.
    When I save the project, close it and load it, I CANT modify it anymore, whereas:

  2. I create a new project and DONT fill out the field “application name” (that is: leave it blank) in the popping up window and move some buttons in window1. When I save the project, close it and load it, I CAN modify it!

Strange behavior indeed.

Anyway, thanks to Michel! I will use your “workaround” and work on a local server.
But how shall the students do so with only an samba-servers available to them???

You mean they have machine with no local disk ?

The only idea I can think of is to delete the older file before saving. That will force the update.

It may be possible to do that with an IDE script.

deleting an existing project that you opened while its open is more than likely going to cause other problems

Then saving by incremental names ?

Thanks again for your answers.

Actually the students do have access to the local harddisk, but when they shut down the computer after class this information is lost when the next student restarts the computer and logs in.

The only “workaround” I see here would be, that the students manually move the project-file, which they had saved to the local harddisk, with the windows file-browser to the samba-server. Which will probably work, but is kind of funny and won´t really confirm everyones trust in the IDE…

But let´s consider this thread to be solved , as I have learned a workaround and it will take some time until I will introduce xojo to my students. Time enough for lots of updates to follow…

Tanks to all

On most machines, you can have a script (Bash on Mac, Bat or CMD on Windows), that executes when it stops. That could be a way to automatically copy the project to the samba drive before the machine actually stops.

Makes me wonder if somehow the file that is saved is marked as read only or locked

Anyone thats seen this happen would you try

  1. create a sample project and save it on the SMB share
  2. now create a new desktop project
  3. in the window open event put
       dim f as folderitem = GetFolderItem("")
       if f.locked then
          msgbox "locked"
       end if
  1. run this project
  2. when the dialog to select a file opens select the projects saved in step 1

Do you get the “locked” msgbox ?