Can't install Feedback - Server could not be reached

I’m using 2016R3 on WIN7.

I download feedback exe, ran it, re-started - still no joy. Or is the Feeback Server down?

If I try from the Help Menu in the IDE it now tells me feedback is not installed and directs me back to the same Xojo downloads page.

I’m going around in circles :frowning:

Feedback recently stopped working on my Mac running 10.8.5

I have a feeling Xojo have upgraded the SSL certificate on their server preventing older operating systems from connecting.

It could be a similar problem although I would have thought Windows 7 should have been new enough.

Thanks Kevin.

This was the first time I’ve wanted to give “feedback” so it’s extra annoying.

Hopefully it’s some other issue and not non support of Windows 7.

Could you two confirm the OS version and version of Feedback you are running?

That’s not the intention.

Thanks Greg, that’s good. Likely an issue at my end.

The Feedback File version is, Product Version 2017r1.1. Downloaded direct from Xojo today.
My OS is Windows 7 Ultimate Service Pack 1.

In searching for that info, I did notice that I had actually tried to install feedback about 6 months back, had no luck then, and forgot all about it. That was Product Version 2016r1.

I probably should uninstall both versions and try again?

Hi Greg.

I’m running Mac OS X 10.8.5 and my version of Feedback is dated: 16th August 2016.

I have also tried the latest version of Feedback (Xojo Feedback 2017r1.1 - 13th June 2017) and that also fails.
Error #505: Unknown socket error #-1200

I’ve assumed it is related to SSL as both and the forums have also recently stopped working in Safari on my Mac (Chrome & Firefox still work).

For Windows 7, if Xojo did improve their SSL, see if this helps:

Yeah, it doesn’t for Feedback. Tried that this morning. We’re looking into it.

The SSL security increase we made on the main website was due to our PCI compliance requirements, so it’s not surprising that you might also not have access to the forum and the store if you’re using an old unsupported browser.

Having done some cursory research, it appears that Safari 6.2.8 (the latest version available for OS X 10.8) only supports TLSv1.0, making it susceptible to the BEAST attack. The new HTTPSocket (which we switched to last year for Feedback) uses the native sockets for connectivity, so that certainly could be the issue.

Looking at Windows 7 with TLSv1.1 and TLSv1.2 turned on I can access both the forum and the store, but Feedback still does not.

We’ll keep looking into this issue and will keep you posted as to what we find.

Also get this message.

Downloaded the latest Feedback App from XOJO website today.

I’m on a Windows 2012R2 server in the cloud.

addendum… I managed to install the App but it crashes with the message Server Could not be reached. Does not even get to the login screen.

Full Message:
The XOJO Feedback server could not be reached.
Feedback requires the ability to communicate with the XOJO server in order to operate. Please try again in a few minutes.

If I can find a copy of Windows 2012r2 server, I’ll check it out.

Got Windows Server 2012r2 installed, installed Feedback 2017r1.2 and it runs just fine.

Please check that you’re not blocking any outgoing ports. If your server requires a proxy, please make sure that the system proxies for port 443 are set up correctly.

Also, make sure that your system is up-to-date.

Thanks Greg. I un-installed the old version and started again.

Working fine now.