Can't get Profiler to work

In a brand new project, I can use Profiler without an issue. But in my app, I cannot. The app runs, but no profiler data appears.

I have no idea how to start troubleshooting this so I wanted to see if anyone else has had this issue.

Kem, I just tried Profiler in 2013 R2 in my rather large project in OSX 10.8.4, and it appears to work. I ran it twice and got 2 different sets of profiling data.

Note : your app has to quit cleanly for the profile data to be saved - if you force-quit it or it crashes, you won’t get any data .

Profiler results seem to be hidden… took me a while to find them

Look in the Navigator… right above BUILD SETTINGS… you should see a RUN item (click show items) and the profile data should be there

Thank you both, but neither of those was it.

What WAS it is sandboxing. My post-process script was setting up sandboxing, so the app couldn’t read/write the profile data (which is odd because it appears to be blocked from writing to Temp). Once I disabled the script, it started working again.

Now I have to see if there is a way for the script to determine if Profiling is turned on.

There isn’t

Well then, a Feedback request will be forthcoming. Thanks.