can't download install exe for windows

I have installed Parallels Desktop 12 for Mac on a Mac Pro (Early 2008, back when they built them right) running OS X 10.10.5 Yosemite.

Installed Windows 10 and basically took all the defaults. Windows seems to be running correctly, can run the admin tools, access the web…

Downloaded Evernote from the Windows Store and it’s working correctly, but see note below.

Tried to download the Windows version of Xojo and after several minutes, the download got very slow and then I got a message that said it could not be downloaded - no other explanation. The same thing happened with trying to install Evernote from the Evernote website. It being a smaller file I tried it again and got the same result. So the problem is apparently with Windows and not the Xojo file.

Does anyone have any suggestions.


Have you tried downloading on your Mac and just transferring the file into Parallels?
If you’re having trouble downloading the installer from Xojo then it’s a Xojo issue, otherwise I can’t imagine how they’re supposed to help.

Also, does Parallels really require you transfer things through USB? I really enjoy being able to drag and drop between VMWare and my Mac.

no parallels doesnt require using a usb
you can set it up so you can drag & drop, or share the mac volumes to windows (or vice versa), run full screen or using coherence mode where windows apps just appear like mac apps and you can switch back & forth quite seamlessly

I make use of sharing volumes all the time to have only one svn repository that I can access from every one of my 13 or so VM’s

Downloaded on the Mac, dragged and dropped to the Windows desktop, installed and ran Eddies Electronics.

Seem to have a good installation.

thanks guys.

William, its either a problem with the bridged/shared network option or that you are using shared profiles and have an anti-virus software on the mac that is stopping the file as the shared “Downloads” folder in Windows actually resides on the mac.

  1. To fix bridged issue: From the Parallels Desktop menu, select Devices | Network Adapter 1 | Bridged Networking | Default Adapter.

  2. To fix the shared profiles problem, turn it off, or find a way to exclude the shared folders from being anti-virus checked on the mac side (probably not the best idea).

I’ve never had Mac AV cause me any issues when trying to install software on any of my Windows VM’s under Parallels
I have had “Windows is installing updates” bog my entire machine to a crawl though