Can't Deploy to Xojo Cloud (again)

Tried deploying my app to Xojo Cloud for the past 12+ hours. At first I was getting this:

Restarted the server and now it’s just stalling here:

This seems to be pretty common with Xojo Cloud, is there something we might be doing wrong that is causing this?

I get this at times too. Seems to happen (to me at least) when someone is visiting the app while I’m uploading. There needs to be an easier way to a) knock users (sessions) offline and b) keep users from accessing the app.

In these situations I normally restart the application. If I still have the problem I restart the server from the Xojo control panel.

Thanks Bob. This is the first upload for the app to a server with no other apps, so there’s definitely no one using it yet. Have restarted the server several times to no avail.

Make sure you send a note to Customer Service.

Actually, you want to send an email to technical support. Posting here is fine and all, but technical support may not see it right away.

For what it’s worth, we made a change yesterday which does more checks To make sure your server is ready to accept an upload before allowing it, which should solve the problem of a restarted server not being ready to accept an upload.

A fix for the 0:00 remaining bug has been submitted for a future release. The solution is often as simple as adding a property or a few characters of code to your project to slightly change its compiled size.

As far as the timeout error, the most common reason is a user app which is consuming all of the cpu. When that happens, our infrastructure usually can’t respond to an upload request fast enough, hence the timeout.

Tom - I just successfully uploaded a test app to your server. I will contact you directly.

I just added a few of lines of code to change the size of the project as Greg suggested and it worked successfully this time.

Not sure about the timeout issue as there haven’t been any apps on that server yet, but looks like I got the first one up successfully now.

[quote=203020:@Paul Lefebvre]Actually, you want to send an email to technical support. Posting here is fine and all, but technical support may not see it right away.[/quote]
I sent an email last night (but to customer service, not prodsupport), just posted here after waiting overnight to see if anyone else had suggestions. Thanks for the help and I’ll try to remember to change up the project size if I run into the timeout when uploading again.

Alright trying to upload an update to the app and it’s getting stuck at 0:00 remaining again. I’ve changed/removed/added code/properties/etc and tried reuploading 10+ times now. Every time it’s getting stuck and I need to force quit and start the whole process over again.

Tried restarting the server and everything several times also.

I’m talking to Tom about this.