Cannot save project directly to Desktop on Windows 10 in 2015r4.1

Just found out that 2015r4.1 doesn’t allow me to save a project directly to the Desktop. 2015r4 works just fine. Is this on purpose?
Windows 10 64-bit. feedback://showreport?report_id=42545

Same version of Windows, save to Desktop quite fine with 2015R4.1.

OK…?

No problems here, either. It may be particular to your machine.

Hmmm… Brand new, reinstalled Windows 10 cleanly from the Microsoft image yesterday.
No other applications showing this problem and 2015r4 running on the same machine works just fine.

Let’s see if anyone else can replicate it- I couldn’t on two test instances of Windows 10.

A work-around for me is to create the file on the Desktop first, rename it and then do a Save in Xojo overwriting the same file.
It only affects the Desktop and no other places, where the save works as expected.
Machine is joined to a domain, but there are no special policies affecting Xojo 2015r4.1…

Never tried that before. I also can’t save to the desktop.

But… How does that manifest exactly ? What is the error message if any ?

What do you mean ?

I’m wondering if this is because this computer is part of a Windows Domain.

When I try to write a file to the desktop with a Xojo debug app there is no problem and checking the folderitem properties IsReadable & IsWritable are both true.

The Windows machine has joined an Active Directory domain.

Also checked my Windows 8.1 machines that are part of the same domain - no problems. Isolated to Windows 10.

This was reported during the 2015r4 beta cycle and no reliable way to reproduce it was ever discerned
The person who did report it reinstalled windows 10 and everything then worked fine
We made NO changes to the IDE related to this for R4 or 4.1

It appears to be “something” in Windows 10 but I’ll be damned if I know what as some people can and some people cannot save to the desktop

This was the previous report (sorry it was 3.1 not saving to the desktop)
https://forum.xojo.com/29328-2015r3-1-wont-save-as-xojo-project-on-windows-10

I still dont know why nor do I have a reliable way to reproduce it

Windows Active directory seems to be a good suspect, as it seems both the OP and Wayne use it.

Just signed in with my old - non-domain user profile & have no problems saving to that desktop. So same hardware, same os, but no AD.

Like I said we haven’t made any fundamental changes to saving projects
We’ve tweaked WHAT gets written into files to make the overall process better but not which files we write etc etc

That you can log in to AD and be blocked then NOT log in and it works suggests some policy in the AD set up for that user account that limits saving to the desktop (cant say what or why but that seems plausible)

Ah perhaps a group policy object and maybe redirected desktops ?

@Norman Palardy I’m just passing along information - the desktop is the last place I’d want to save a project to. A simple workaround is to create a folder on the desktop which you can do from the save as dialog and put the project in there.

Another interesting little factoid is that I can save my project to the desktop with a shorter extension e.g. untitled.rbp, which tends to indicate there is a naming policy, not a permissions policy involved. But I can create a folder on my desktop called “untitled.xojo binary project”, so ???

That you can do this when you do not join vs cant when you do definitely suggests “something” in the AD policies

Which is fine by me as that makes it “not a bug” in Xojo

I think Scott Boss ran into this with 2015r3.1 but AD never seemed to come up in that conversation

Well, I don’t want to be the one causing rain on your parade, but 2015r4 does work on my machine even when joined to a domain.
My problem with bugs like this is that since Xojo IDE is written in Xojo bugs like this may affect our own programs written in Xojo.