Cannot get Real Studio to run

I’m posting this here because I’ve emailed customer supported twice over the last 24 hours and heard nothing back.

I am trying to get an old version of Real Studio running inside a VM running macOS 10.14.

I dug up an old Real Studio license that expired on 21st December 2013 by digging through my licenses page on xojo.com.

Using Real Studio 2012r2.1 (released Jan 23rd 2013) I get this error message when I enter my serial number:

I used the tool at https://www.xojo.com/account/studio_activation/authcode/index.php to generate the authorisation code. When I enter it however I get this error:



How do I fix this? I’m not sure what is wrong. The VM has internet access as I can browse the web in Safari.

You have to wait 2 minutes between getting the dialog and entering the number.
So when you see the error, just wait longer and try same code again.

1 Like

Thanks Christian but no joy. No amount of waiting seems to work. Does the IDE have to have internet connectivity? I’m wondering if the IDE splash screen is having difficulty connecting to the internet (or is trying a server that no longer exists). The VM definitely has network connectivity though.

Any thoughts @Alyssa_Foley or @Dana_Brown?

It’s a time synchronization thing.
So first the dialog open, then go to Xojo website. Make sure between dialog opening and pressing button is 2 minutes.
Worked for me earlier this year.

1 Like

Christian is right, you need to make sure you are waiting on the screen for the full two minutes otherwise you will see that error.

It worked!

Thank you guys. I just had to wait a few minutes like you said.

2 Likes

Glad you’re all set Garry.

We’ll archive your Customer Service emails, but to be clear, we generally reply to emails very quickly, often within a few hours, but both of your messages came in within 30 minutes of each other in the middle of our night (about 7 hours ago). We do not usually respond in the middle of the night, although it has been known to happen on occasion. :slight_smile: Officially we guarantee a response within 48 hours.

5 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.