Cannot Deploy

Hi since one week I can’t deploy my WebApps to the Cloud.

If I click on deploy it starts to build, but after opening the Building-Folder it stops. Last week I had the issue with the upcounting time several times.

I restarted the server, renamed it, tried it on Mac and Windows, it doesn’t work!

It is really important, that I can update my apps!

Since I purchased the XC this issues appeared several times, but after waiting or multiple trying it worked mostly. But not this time…

I need to know the exact behavior and error you are getting to be able to solve this for you.

There’s no error! It stops only and do nothing!

Ok, but where does it stop? During upload? Preparing?

during preparing. the “builds”-Folder opens, then occurs usually the upload-bar, but there happens nothing!

Aha! Did you happen to turn off the “use builds folder” preference?

No “Use Builds Folder” = ‘ON’

Now I have tried the following: I connected my Mac with my iPad over the personal hotspot. Then I deployed my app.

First it seemed that it works: the progressbar increased. The time counted down. But a little bit before finishing (ca. 99 %) the PB stopped. The remaining-time stoped at 0:00, noting else happens. The last 1% is still lacking.

The App isn’t uploaded to the Server

After 10 Minutes waiting I had to close xojo over the mac-taskmanager

Okay, I have enough now!

I’ll quit my xojo-cloud. XC is a good idea and could make the hosting easier, but in this current stage it’s not usable.

I have to supply my clients with a stable and reliable software. Thats not possible with the XC, unfortunately. It’s easier to load the files via SFTP to a Webserver, than waiting and hoping, that the deployment works.


In this case, try 1701software: This is a Xojo dedicated hosting, powerful, open, cheap, and with the possibility to choose a host in Europe. It is a host appreciated by many Xojo users.