Cannot connect to the debugger


i use the newest version of xojo, 2014.1 on OS X 10.9.2 and every time i run a project i get the following error-message:

The projects are all stored in my dropbox, so this is maybe some kind of reason. What is the debuggers problem and how can i fix this?

Thanks for helping.


nobody else facing this problem?

Had this happen to me last week. I changed the path where it stores the Debug file to the desktop and it worked fine.

hmm. made a local temp-folder and changed the path for the debug-files to this folder, but no change. Same error here when running my app.

how are you getting the debug app on whatever machine its running on ?
is the machine you run the project on the same one the IDE is running on ?

Hi Norman,

the machine where the ide is running is the same as the machine where the debugger is running (inside the ide).

Found my problem. I was using AppWrapperMini for this project and in the build-settings there is the AppWrapperMini-Option “Behavior” which controls when to use the AppWrapperMini-Build-Script. It was set to both (Release and Debug). After changing this to Release only, my Debugger-Error was gone.


AH so it was sandboxing it and preventing them from connecting ?

Don’t really know the detailed reason, but i also think it has something todo with sandboxing.


I’m getting the same problem, but it’s on 2016r1.1

The first version of my desktop app had a build step script.
Now, after change my app, and remove the build step script, when i run the compiled version, i get the same message!

How can i fix it?

Best regards,