Cannot Access the Language Reference

I need help with the LR. I am on 2016R4.1 on Win 10.

I cannot access the local local built-in language reference. I click > Help > Language Reference: The Language Reference menu shows up in the task bar at the bottom but it is almost like it is off-screen and not displayed on the monitor. It shows up in Task Manager and appears to be running but I simply cannot access the window. Clicking on the LR ICON on the task bar selects it but it doesn’t bring up the window.

Any help appreciated. Thanks.

Select the icon in the task bar and press + Space then press m. After that use the arrow keys or mouse to position the window.

Got it back, thanks Wayne!

Unfortunately I have to do this every time I start the language reference. It is like there is a configuration or settings file somewhere that is not remembering the last window location. It always paints the window off screen when the language reference is opened.

HKEY_CURRENT_USER > SOFTWARE > XOJO > XOJO
Language Reference Height
Language Reference Left
Language Reference Top
Language Reference Width
Language Reference MinMaxed

Hi Norman,

Thanks, adjusting those worked, the values were way out sight. However I believe it is an area to be looked at. IF the language reference is minimized when the IDE quits then it is inaccessible, or at least difficult to access during next launch of the IDE. When launched the window for the language reference is on the task bar but clicking on it does not restore the window. This is also true if you right click on the minimized window on the task bar and click close. Next time you launch language reference you cannot restore the window without using the ALT Space Bar, but in my case the menu to maximize or minimize was way off screen. Even when it is on screen when the window is minimized on the task bar the “Maximize” option is grayed out.

Something is a little off as it does not behave like traditional windows nor the IDE itself.

The web language reference http://developer.xojo.com/home seems to be offline tonight (European time). For instance http://documentation.xojo.com/index.php/Canvas gives no reply. Anything under Reference.ClassicFramework gives no result.

Same here. :frowning:

We’re aware of it and are working on the issue.

Of course you can CAN always use the built in local reference and continue

Note that http://developer.xojo.com is not offline, but the wiki (http://documentation.xojo.com) that it links to for some pages is having trouble right now. As Norman said, use the local Language Reference for the time being.

Go into Preferences/Options and set “When seeking help” to “Use built-in documentation”.

[quote=315119:@Norman Palardy]We’re aware of it and are working on the issue.

Of course you can CAN always use the built in local reference and continue[/quote]

I’ve got so used to Googling what I need to know that I’d forgotten there was a local reference! Doh!

I have done that, but it gives no repons other than a black Language Reference webpage. (I run Windows 10 with r2016v4.1).