Build step, Copy Files no go - remote debug Mac to Win

I have a bunch of folders with application data I transfer in buid scripts. Im developing on my main Mac Catalina and remote debugging onto an M1 and a Win10. Everything seems to work great except one file in one folder which is 848kb in the source folder but shows up on the Win remote as 1k. Ive tried it 9 ways to sunday but it just doesnt seem to pick it up.
Has anyone experienced this or maybe know whats causing it?

What’s the name of the file?


Any chance there is some hidden character in the filename?

i just tried it as “hondo.jpg” and its exactly the same, 1k. ugh

ive also tried zipping it but no matter what I try it wont copy - hundreds of other files copy just fine. Ive also tried moving to other destinations, no-go

Well, I think you’re on to it Kem, its definately an issue with the .rdb file extension as part of some dark web stuff (?) and no doubt win security which i dont have time to figure out right now. I’ll try to repost this when/if I get it figured out. It just means I have to run some scripts but its awfully annoying. I tried sending the file to my gsuite drive and then to the other machine via download and the same thing happened so its not xojo or the Copy Files script mechanism.

1 Like