Bug report

(1) I can’t create a ‘case’ using feedback - the Case->Create New Case menu item is grey out!
(2) I have experienced a bug where:
(a) I have a class within a module, the class has a public shared method. The shared method does not appear in code completion when I type the ModuleName.ClassName. elsewhere in my code but if I type the name and parameters it compiles and works correctly.
(b) When I type code within the shared method (mentioned above) code completion does not work. If I right click and ‘Convert to Regular’ then code completion works.

There may be more code completion issues that are related (such as shared methods not in a module and shared properties etc.) but I have not investigated them

Could somebody file a case for this if they are confident that they see the same behaviour please?

You need to search for a similar case first, then if one is not found you can create a new one otherwise add to the existing case.

Thanks for that help Wayne it was not obvious to me that I needed to search first, it would be a great place for a ‘wizard’ kind of workflow instead of just a greyed out option.

I searched, typed in the details, set the drop-down options and got back the error message: Communication with the Feedback master server has failed. Error #104: XML error: not well-formed (invalid token) at line 1. - What??

Could this be because I had in the description?

Anyways - I am getting a bit frustrated with Xojo - it seems that everywhere I turn I get a problem, crash, bug or other inconsistency. I do like the product but the negativity is building up.

Nothing bad intention towards anyone but I really don’t have time to fight a bug reporting system in order to try and help to improve the product - so if someone from Xojo cares enough then please add this bug to the list.

[quote=22460:@Carl Clarke]Could this be because I had in the description?
[/quote]

Could well have been. All software has bugs, but a bug reporting bug is VERY frustrating - I’ve just logged a bug for feedback now (a different one).

I can understand your frustration, but it will be worth hanging in there. The platform is extremely powerful and very RAD once you get to know it’s foibles.

Oh and it’s not the that’s the problem see feedback://showreport?report_id=28412.

Thanks for trying and the encouragement Wayne - I do like the product but just find it very frustrating at times. If I was Mr Xojo I would be really kicking some * to get proper automated testing in place rather than rely heavily on the community. I am sure that things are improving though.

The bug that I experienced with code completion still stands.

I have tried to create a case for this 3 more times and each time I get the same error #104

I set the product and category to:

Xojo, IDE, Auto completion

I set the type to:

Bug

I set the description to:

I have experienced a bug where:

(a) I have a class within a module, the class has a public shared method. The shared method does not appear in code completion when I type the ModuleName.ClassName. (and no grey dots) elsewhere in my code but if I type the name and parameters it compiles and works correctly.

(b) When I type code within the shared method (mentioned above) code completion does not work. If I right click and ‘Convert to Regular’ then code completion works.
There may be more code completion issues that are related (such as shared methods not in a module and shared properties etc.) but I have not investigated them

Boom! Error #104

Take out the < and > from your description. It’s probably causing the xml error. If so, it is definitely a bug.

Create new menu item remains disabled to me, even after applying a search, since 2013 R4.1.