Big Bug in Webapp-Deploy - XojoCloud


I signed up to the xojo-cloud. then I downloaded the IDE 2014R1 and clicked “deploy” to load up one of my applications.

The progressbar did increase ca. 20%, then it stopped and the “remaining time” started to count up. After 10 minutes waiting, it shows, that 115 minutes is the remaining time.

It’s not possible to close the IDE.

Now I broke up the process and try it again!

now it worked

upload to cloud is bad from Germany. At least for me.
Better wait till there is an European data center.

so I had to know it before!

when comes the european version?

There is no time announced.

poorly. I do host my apps on a jiffybox so far (known from your MBS-Tutorial). But it’s very hard to manage such a server. So I thought, the Xojocloud could help me saving time and nervs.

We’re aware of that bug, but so far have been unable to reproduce it reliably enough to fix it. Be assured that we do want to fix it though.

Today I try it again and:


here’s a video:

I just uploaded today. First try failed and I waited very long before I killed Xojo. Second attempt worked.
(but I deleted app on server in-between)

Jep, second try works!

I live in Norway. Many times every evening goes offline.

Sometimes thats not our fault either or anything we can control

Things like, and also things like akamais tools can help show where / if there are bottles neck in various places

I will give ut a go!
offline again 5 minutes ago

trace route can be instructive too

[quote=71687:@Kato Gangstad]I will give ut a go!
offline again 5 minutes ago[/quote]
I can tell you this, if our site was down today, we would have had sirens going off… And we didn’t.

try the free tool called MTR see

You might have to download it and compile it but it gives a pretty decent overview of whats going on & where and has been recommended to us by certain service providers to help diagnose whats going on

And there’s this how to read & diagnose network issues with MTR :stuck_out_tongue:

Offline just now… 15 minutes downtime
Did a Traceroute from my computer now.


When it’s ok it looks like this:

So one of the things to remember is that our firewall actively denies pings if it gets a lot of them from the same source. It could be that it is just protecting itself.