Bevel Button Strangeness

I have a toolbar made of bevel buttons,… each button is identical except for its icon (no text)

All the icons work except one … for that one the icon appears 1/2 the size, and not centered

Note : all the properties of the button matchs the other 14… the @1x and @2x images match (size, points etc), obviously the picture is different

Any ideas? If I copy one of the other icons into this button it works… so it must be the image…
I have tried starting from scratch… to no avail.

Check the resolution (ppi) of the image. I suspect it’s 144 when it should be 72.

no… it is 72
and what is strange is those icons that DO work are 144…

and this one … if I do change it to 144 then Xojo says “will be scaled”… but it doesn’t say that for the others :frowning:

sigh… not sure what I did or didn’t to (or if the electrons just realigned… now it works )

Thanks

ImageSet:
Display the icons in Xojo,
Clear the icons,
Drop it (one by one ?) from the Finder,
Run.

Now OK ?

I had to do that this afternoon to get the correct size in an example after resizing one icon. The ImageSet keeps the previous one (how, why…).