Arrays in Debugger "open in New Window" no Data

Hi,

I’m new to xojo 2021 R3.1, I’m using the Demoversion for Testing. My last licensed Copy was 2014.xxxx :innocent:

At a breakpoint the debugger stops, now i try to Expand an Array with “open in New Window”, but there ar no Entrys.

Is this only a “DEMO” Problem or is it a bug?

Edit: Using Windows 10 PRO 64

Xojo1
Xojo2

I think this is an unimplemented feature. That option has been there for a while, few know about it, and it’s never worked as expected.

See the Result from my old 2014 R3.1

Xojo1
Xojo2

I stand corrected.

Its a bug I reported 18 month ago.

Case: 61856.

1 Like

Oh, OK, that’s a long time!
In complexe debug situations, this is a “must have” feature for me.Why does it take so long to fix it?

@Geoff_Perlman
unbelievable …

2 Likes

As I’ve been saying for years now, stop fiddling with the language and fix the IDE. If the tools are frustrating to use, little else matters.

5 Likes

It’s frustrating not to have it especially since the debugger variable panel is awful to use.

My guess is that it’s not a well known feature as it has been broken for 6/7 years and I had to attach a screen recording to the case as they didn’t know what I was talking about.

2 Likes

Xojo Arrays are usually shown for me, but it sometimes takes a while for the debugger to update the display and really show their content.

I found myself duplicating all kinds of macOS structure computed properties anyway with a translation to Xojo classes because the debugger some 2 or so years ago lost the ability to show structures. ;(

I take a look on this Case,
Rank:none, Points 0 what does that mean ? Will never be fixed?

It’s supposed to be great that the IDE is written in Xojo, because that means that the devs who use it every day will notice all the bugs and bad design in it and fix them regardless of “points” or “rank”, because they take pride in their work and want to make a great product. Unfortunately that doesn’t seem to be the case, and a lot less pride and love and care seems to be lavished on it than went into RealStudio, which was written in C++. For example, Help Text, a wonderful feature that I (and I would think anyone who uses Xojo) use constantly, has never worked right since the day Xojo was born.

2 Likes

I wrote this Text via “Google Translator” because my english ist verry bad at this Time, forgive me :upside_down_face:

I think XOJO is a great development environment, the only thing that bothers me is that it takes forever to fix bugs.

I mean, of course you have to differentiate how important it is to eliminate individual errors.
If an error occurs somewhere in the program logic, I can program around it.

But if something doesn’t work in the IDE, I’m powerless.

I am surprised that the error described was not noticed by almost anyone over a period of 7 years.

I think that it would be imperative to make sure that the IDE you work with all the time works properly. But I also suspect that it is an extremely complex sensitive construct.

In short, 18 months and no fix in sight, that must not be. I can’t imagine that the developers of XOJO use the debugger when developing XOJO. At least not in a version after 2016, because then such things should have been noticed already.

1 Like

Hmm, this looks good for me (Windows 10)
Xojo1

it does show them but the IDE will crash if you click them (mainly external pointed structures).

So different behaviour too?
In my case please note Frame and Bounds. They don’t appear in the debugger at all. I used Xojo translations (not shown in screenshots) as additional computed properties to Rect to have them available in debugger. The same with other macOS CoreGraphics structures (NSSize, NSPoint).

if computed properties can be called then the debugger may not show anything. Altough i think it shouls always be showing something.