Anyone know how to override this in the Info.plist in the build process.

<key>UIRequiredDeviceCapabilities</key> <array><string>arm64</string> </array>

I’ve tried to leave it blank or substitute armv7 but it won’t deploy to my iPad running iOS 9.3 which is not updatable anymore. My App is in the App Store but I really want to test it on my old iPad and also use the App without having to buy a new iPad.

Building with an older version of Xcode maybe?

Current versions of Xojo only build 64-bit iOS apps so changing the plist won’t help with that. You’d need to use an older version of Xojo (and the corresponding older version of Xcode) to build a Universal Binary that has a 32-bit component. I think 2016r4 or earlier might work.

Thanks Paul. Now I can stop wasting time with the plist experiments. I’ve had lots of trouble in the past with older versions of Xcode trying to commingle with newer versions of Xojo until they were removed so I’m going to think it through very carefully first before I give it a try. Right now all is well with builds and the App Store and that’s always a bit precarious so maybe this is a case where if it ain’t broke, don’t fix it.

I have Xojo 2015, and Xcode 8 and 9 installed.
Although 2015 sees my licence for iOS (bought this week), it wont build
Do I need to tell it where Xcode 8 lives, or use a completely different development machine?

Xcode > Preferences>Locations

and see if the Command Line Tools window shows the version of Xcode that you want to build with. You should be able to select either 8 or 9.

Another option to avoid any co-mingling issues is to set up virtual machines with the older versions of macOS/Xcode/Xojo that you can use for building for these older devices.

Oddly, opening 2015 and starting an empty iOS project, it will build.
Open the current project or paste code from it into 2015, Build doesnt work any more.
Odd, not losing sleep over it now though


Thank you for the suggestion. That option never occurred to me. I’ll let you know if it works. Do you know what the latest version of Xojo might do the job?

And for Jeff. I had the same problem when moving to 2018r1 from 2017r3. I finally got it to build doing what you did but I don’t know how it happened. I was shotgunning the whole operation and it finally worked. It might be a matter of your app not finding the external resources it needs if you’ve moved your project around to different folders.

I think 2016r4 or earlier should work.


It worked. Partitioned the disk on my Mac installed the OS and 2016r4 and after some gyrations the App is on my iPad running armv7 and iOS 9.3. Thanks for steering me in the right direction.