Application Loader ERROR ITMS-90232

after installing Sierra, when I try uploading a pkg to itunesconnect, Application Loader v.3, before starting the proper upload-process, stops with the following message: ERROR ITMS-90232: “The product archive is invalid. An installer package containing an application bundle was not found in the archive.”

I installed Sierra last week, and before installing it, running Yosemite, Application Loader worked all right.
Sam asked for the pkg, and after examining it, he could not find any problem (thank you, Sam).
Xcode is the last version available, and my certificates seem up to date.
Installing the pkg on my machine works OK.
I even created a new Xojo app: just one window without any object or code, except a legit bundle ID and a proper app-icon; but Application Loader came up with the same error.
Disk Utility says my machine is OK.
I restarted the MBP several times.

Any suggestion? Thank you.

as it happens, after one week of useless struggle, the problem was solved uploading the pkg through Xcode > Open Dev. Tool > Application Loader.

Xcode’s Application Loader is version 3.6, while Application Loader downloaded clicking its name in iTunesconnect is version 3.
I guess Sierra likes 3.6.