Apple Transporter selects wrong language

Just trying to use Apple Transporter for the first time. When I load my app in to Transporter it shows the app’s name in a different language (Chinese).

The app does have multiple languages in it but it is built in English. Further on AppStoreConnect, English is selected as the Primary language.

Any ideas?

Select Xojo > Navigator > Build Settings > Shared
Now in Inspector > Build > Language

What is the selected Language?


If you submit, does it show correctly in App Store Connect?

I will find out tomorrow and let you know…

Well, the answer appears to be that it submitted OK and the content looks correct on AppStoreConnect. Will now wait to see if there are any problems in the review process.

1 Like

Clearly there is something wrong. The app loads OK and shows correctly in the app store, but when I look at its details in App Annie - it shows in Spanish!

I have the same problem in AppAnnie, some apps in English, others in French or even Spanish.
As long as it doesn’t display in a language I can’t read I’m ok with it.

Do you use App Wrapper?

If you have App Wrapper 3.11; I added App Store delivery, but I kept it hidden while I’ve been testing it. You can trigger it, by wrapping for the App Store, then opening the Notarize window and dragging the .pkg file into the window. You have to manually specify the bundle identifier and bundle version.

Maybe this will work?

Sounds like a good addition to App Wrapper (one less app to run) - I will test on my next upload.

1 Like

Hopefully it’ll work for you. I’ve been a bit anxious about replacing an Apple tool.

Yes it worked Sam. There was a slight glitch when trying to add the Export Compliance part when choosing the build in appstoreConnect - but I think that might have been an internet glitch. It worked when I clicked export compliance a second time.

One less step to nirvana. Only about a dozen left to eliminate.

1 Like

Thank you for letting me know. A future version will enable auto-uploading to the App Store. So you just wrap, and get on with your life.

It’s not there yet, because the more automated I make it, the more chance of it going wrong…