App will not run after reboot. OSX

I have used Xojo for many years and never seen this. About 2 weeks ago it started that when I build an app, it will run. But after reboot, it will not run. There is box that says app cannot be opened due to a problem, check with the developer to make sure this app works with this version of OSX.

I have recently put on Yosemite, but not sure if that is a direct cause and effect. Below are a section of the report.

Any suggestions on getting this fixed?

Crashed Thread: 0

Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @executable_path/…/Frameworks/XojoFramework.framework/Versions/A/XojoFramework
Referenced from: /Users/USER/Desktop/
Reason: no suitable image found. Did find:
/Users/user/Desktop/…/Frameworks/XojoFramework.framework/Versions/A/XojoFramework: code signature invalid for ‘/Users/user/Desktop/…/Frameworks/XojoFramework.framework/Versions/A/XojoFramework’

/Users/user/Desktop/ code signature invalid for '/Users/user/Desktop/'

Binary Images:
0x8fe64000 - 0x8fe97e03 dyld (353.2.1) /usr/lib/dyld
0x93595000 - 0x93596fff libSystem.B.dylib (1213) <77FA0B3F-4412-31F6-A798-21D068AE16C3> /usr/lib/libSystem.B.dylib

Idem, see :

I have multiple apps that no longer boot on OSX Yosemite 10.10.1. Each time I want to use the apps, I have to build after each boot up and they work fine until restart or power on. Can someone offer any advice on how to solve this?

I often have this problem with applications in Dropbox folder, hence I thought the guilty was Dropbox.
But now I realize this only happens with Xojo applications…

I really have no idea what could cause this. Have you tried another user account or another Mac (or VM) to see if you can isolate the problem?

For what it worth, it seems happening much more frequently (if not only) on the machine where the application was built.

OK so it is a dropbox related problem. My collaborator and I have been using dropbox for a long time without issue(both on Mac, both on the lastest Yosemite but I have a Mac Pro tower and my collaborator is on Mac Book Pro). This is a recent issue within the past few weeks, coincidentally after moving up to Yosemite. If I drag that droxbox build and content to the desktop, it still fails. But if I drag the Xojo project and content to the desktop and make a fresh build, then it will restart. This is a work around but certainly will make for lots of hassles collaborating. At least this solves the bigger immediate problem though.


For what it’s worth, I ran into something similar to this a few months ago. Dropbox is not syncing the frameworks properly. It copies them, the OS no longer sees the framework as a bundle, but just as a folder.

I ended up having to change how I was using Dropbox because of this. I still maintain the project repository in Dropbox, but the build folder has to be in a local, non-synced folder. Then, if we have to place a .zip archive of the build application back into Dropbox in order to share between systems.

I have never tried to build to a different folder than the project, so that may be perfect solution as we never share builds only projects and content. Thanks

If building a project that is located on drop box creates an app that does not work but copying the project locally & building works then this suggests “something” about dropbox is at fault.
Can’t tell you what though as I dont know

When you get one of these apps PLEASE compress it and attach it to a bug report to us
I think I know whats going on

And I truly suspect this is NOT our bug but DropBox’s

One of the most obvious reasons would be that DropBox uses a non Mac OS file system. So no permissions, and broken bundles. Your app does not start because building on an alien file system breaks all permissions within. Just as if one builds on PC, opens the Tar archive and copies the result.

Dropbox or any cloud folder for that matter is bad for saving projects and building. The issue has been documented many times.

Copy the project folder to your local disk and everything will be fine.

Three words: Source Code Control. Dropbox isn’t a good tool for sharing code.

I guess this is a Dropbox+Yosemite problem because it started when I upgraded to Yosemite. The only strange fact is this only appear to happens with Xojo applications and, specifically, with the Xojo.framework. Though I didn’t test extensively with other applications.

Now, I tried to compare a such “damaged” application with another identical but residing outside Dropbox.
I compared all files in the bundle byte by byte and the two applications are IDENTICAL.
In fact, just copying the “damaged” application in another place and then replacing the original one with the copy, solve the the problem. Not the same moving the application somewhere else and then moving it again on Dropbox: still doesn’t work.

I also tried to check the validity of the Xojo.framework signature with codesign. Again it’s valid.

Hence, the problem must be somewhere else than the binary…

I’d like to spot where the problem is, just to give some hints to the Dropbox+Apple guys on solving the problem.

[quote=171573:@Massimo Valle]Hence, the problem must be somewhere else than the binary…

I’d like to spot where the problem is, just to give some hints to the Dropbox+Apple guys on solving the problem.[/quote]

Try permissions. Try symbolic links. Most probably what is messing up.