App.Name Syntax Error?

Hey guys, I’m having a major issue with Xojo 2018 R3. I’ve tried everything I can think of. My app simply will not compile. It gets to the very end, and then highlights the App class in the source list and gives me the following error:

App.Name - Syntax error - App

What in the world can I do to fix this? I’ve lost a ton of time trying to get this sorted, and I really need to get back to working on my new release. I don’t want to go back to R2 because Dark Mode is a big feature I’m needing in this release, and I’m desperately needing the incremental build features. Working with R2 is unbelievably slow and seriously affecting productivity.

What is causing this problem? Any suggestions for how to fix?

Thank you very much.

By the way the app compiles fine with R2, and I haven’t made any changes. It just refuses to compile or build in R3.


App Name Error

Thanks, I’ll check that. By the way, I searched the forum for “” and I get no results. Is the search function broken?

Nothing in that post relates to my issue. I have a very simple App setup. I’ve also tried removing all code and properties from it to test. Still won’t build. My build settings are correct. I’ve tried duplicating the project, deleting the Builds folder, clearing caches, still no go. This has been happening for weeks, since R3 was released.


My opinion is to try using a Google “Xojo (insert search term here)”

For me brings up forum posts and Xojo docs results

I hope someone else can chime in here as I have not experienced this error and took my main project from 2016 R3 to 2018 R3 without a problem (build problem)

Sorry that post didn’t help

Thank you, that is a good tip. Now I’m even more confused — I just literally deleted everything from my App class - it’s empty. Still getting the error message…

When you get a syntax error on really weird objects it’s usually (fixable) project corruption. File a feedback case and privately attach your project file. This will help them find where the problem is so they can fix it for everyone.

Thank you. I downloaded the feedback app and used the search there and it pointed me here:

It was how my version number was entered. It is building now. But holy moly, R3 broke so much stuff in my project regarding graphics. I can’t even put an icon in the listbox using celltextpaint anymore? Getting repeated hard crashes (like Xojo itself is crashing…). Oy, onto the next issue.

Thank you Tim, I appreciate your assistance!