"App Installation failed"...

This has been discussed many times here and I have really tried to find a solution, but so far no luck.
A couple of weeks ago I opened the iOS parts of Xojo 2016r3 and actually started looking at it. The first problem I found was that the “Team” popup under Code Signing was completely blank. This even though I could develop and install apps from Xcode.
Finally found a possible culprit - my name in the codesigning certificate contains “ö”. I remember this from my development days in Titanium (where they fixed their IDE to handle this). I contacted Apple and they updated by registration in Apple Dev Portal to be “Sandstrom”.
I removed all certificates from the Apple Dev Portal and my local Keyring.
I then tried follow the (old) instructions from developer.xojo.com and now at least I have a team showing up in Xojo. “Great” I thought.
Create a test project from the AnalogClock example, got the wildcard profile etc. When compiling I only get the .app file, the .dSYM file is not created. Also copying the app-file to the phone (that is registered and got the Provisioning Profile installed) gives me the “App Installation Failed. No code signature found” error.

I have repeated the steps above (clearing out certs etc) but still the same problem from Xojo. I created a new sample project in Xcode and used the same bundle ID - all works.

Is Xojo creating some sort of lg-file when compiling and code-signing that could be of any use troubleshooting this?
Have I missed an updated how-to for getting this to work?

Any help greatly appreciated.

Running Xojo 2016r4.1 and Xcode 8.2

As far as the provisioning profile goes, I never had any luck with a wildcard profile. Making an app-specific profile has worked for me.

No go with specific provisioning profiles either. Maybe I’m too thick to develop for iOS using Xojo.
Just a question - when you hit “Build” in Xojo do you get one (app) or two files (app+dSYM) as discussed in the how-to article.
I still only get the app file that doesn’t work.

OSX 10.12.2, Xojo 2016r4.1 and Xcode 8.2

I get both. Don’t know what to tell you.

OK, good to know. Seems like there is something really broken in the Xojo-Xcode integration.
May I ask a final question? What version of OSX and Xcode are you running?

Mac OS Sierra 10.12.1 and Xcode 8.1, but this sounds like a Xojo problem in not creating the dSym file.


When I compile my latest iOS project with 2016R4.1 under 10.12.3, I do get both the .app and the dSYM file.

Same thing with 2016R3…

You use Xcode 8.2?

No. 7.3. I usually never upgrade unless forced.

Yeah, maybe that’s where my problem is.

Hmm… Removed Xcode 8.2 and installed Xcode 7.3.1 but still same problem - I only get one file when building. I guess it’s never to late to simply give up.

At any rate you don’t need the dSYM to upload to the App Store…

Since I can’t compile or test on a device the App Store is far away…

If you have the .app you can install on the device with XCode. Yet again, no need for the dSYM.

Usually when I don’t get a dysm file its because the team isn’t set right. Are you sure that the team is correct and you have the signing certificate and everything installed on your computer associated with the app’s bundle ID?

Thanks to your and @Michel Bujardet for all help

To the best of my knowledge, especially since I can build and install apps created in Xcode on the devices, using both Xcode 8.2 and Xcode 7.3.1.

Checking the app-file after Xojo has built it I see:

nanna:iOS msa$ codesign -v AnalogClock.app AnalogClock.app: code object is not signed at all In architecture: armv7 nanna:iOS msa$ codesign -s "iPhone Developer: Mattias Sandstroem (D995T247ZR)" -v AnalogClock.app AnalogClock.app: resource fork, Finder information, or similar detritus not allowed nanna:iOS msa$ xattr -c -r ./AnalogClock.app nanna:iOS msa$ codesign -s "iPhone Developer: Mattias Sandstroem (D995T247ZR)" -v AnalogClock.app AnalogClock.app: signed app bundle with Mach-O universal (armv7 arm64) [com.tangix.xojoclock20161216]
After this, looks like getting closer because Xcode now complains about “The application could not be verified”, I guess this is due to no provisioning profile is included.

My take is that Xojo for some reason can’t build on my machine and the resulting .app-file is junked. I have tried setting up a completely new login-profile but still the same problem.

I have this problem, too. From fishing around in the web, it seems to be a problem with Xcode 8.x. People doing Objective-C or Swift development are having problems, too.

Any clues yet as to how to solve it?

Go back to XCode 7.x.

I couldn’t find one and eventually gave up on this.
Downgrading to 7.3.1 was not a solution, maybe xcode 8 borked my installation of tools, I’m not sure.
Way back when it was possible to download a script from Apple to completely uninstall xcode, but that seems to have been lost knowledge.