Anybody Else Getting This Critical Xojo Bug

This bug is critical IMHO and I was wondering if anybody else has come across it. Xojo’s text position in editor is a bit off and makes the code editor annoying to use. I have no idea how to reproduce this other than to install Windows and Xojo.

It’s the blinker that is not in the right position and also there is spaces between text that come up in the editor so the text is clearly not rendered how its meant to be.


Try using another font for the code editor. Ones that have fractional character widths will do the this. Try something monospaced instead.

Which one? I have tried changing the font. Also, I thought the issue might be to do with MacType (a font rendering alternative to the native one) but I have uninstalled that.

Try with Lucida Console. It is monospaced and very legible.

Start with Courier. That one is definitely monospaced. If that doesn’t suit you, do a search for “monospaced fonts” on the web.

I think that solved the problem. Thanks. So the problem is not as big as I thought it would be but it means less font choice.

Here are some other monospaced fonts mentioned that are used by other Xojo developers.

I’m a Menlo kind of guy.