Another Trip Down "Failed to Locate Framework DLL" Lane

OK … this one’s just plain bizarre!

First of all, my setup is:

  • Windows 7 Professional Service Pack 1
  • Xojo 2016 r1.1
  • 32-bit app build architecture selected

I have a folder on my hard drive that has about a half dozen build folders of compiled programs I’ve written over the past 6 months. Each of them contains the executable and the two supporting libs folders. As of 10:40 pm last night, all of them worked fine (clicking on the executable opened and ran the program as it should. The computer was left on and nobody touched my computer overnight. This morning at 6:45 am, here’s what I get when I try running those very same executables:

  1. Some of them work just fine.
  2. Some of them just sit and stare at me when I double click the executable to open the program (e.g., nothing happens … program doesn’t open).
  3. Some of them throw the runtime error “Failed to Locate Framework DLL”.

I have scoured the different applications looking for anything “different” but have found nothing (besides, these have been working all along until last night). I searched the forum and found a number of threads but none seem to address my symptoms.

Unless the evil computer bug fairies came overnight and pooped on my build folders, NOTHING changed! No Windows updates occurred (I have them turned off … besides MS killed Win 7 updates already). I tried rebooting the computer with no luck. I did not try re-installing Xojo (mainly because of some of the findings below … which indicate a re-install is not the issue).

Now, comes the really good part:

  1. I can open the same projects that won’t run from the builds folder executable and run them just fine from the IDE Debugger without any issue. If I then hit the build button, they seem to compile just fine (e.g., creates the build folder with the executable and supporting libs folders). But clicking on the executable then throws the Failed to Locate Framework DLL runtime error.
  2. I can take the exact same build folder from #1 above that wouldn’t work and copy it to the Desktop on the same machine and it DOES work without any errors.
  3. I can copy the folder with all the binary projects and build folders over to my Surface PRO 6 with Win 10 Home and they all work fine executing them from their respective build folders.
  4. I can open the project on my Win 10 computer, compile it and it runs just fine on the Win 10 computer.
  5. If I take the build folder compiled on Win 10 from #4 above that worked, and copy it back to the Win 7 machine in the same folder where it originally was, it once again throws the error.

I did notice in all the copying and pasting I did, that several times it gave me the message that what I was attempting to do (e.g., copy/paste) could not be done because the file names/paths were “too long”. This happened when I tried copying from the folder on the Win 7 machine directly to the folder on the Win 10 machine. Each of those folders does have a fairly lengthy path, for example

C:\Users\Don\Documents\Customer Projects\Hillphoenix\Miscellaneous\Publix Shelving Catalog Project\Builds - Publix Shelving Kit Finder App_070221_0833-2.xojo_binary_project

Could this have anything to do with it? If so, why has it worked all along until now?

This is a real head scratcher … anyone have any ideas???

Thanks in advance … Don

Maybe some antivirus shenanigans?

Thanks for responding, Bill. First of all, both the Win 7 and Win 10 machines use the same Trend Micro anti-virus software. The fact that the issue does not surface on the Win 10 machine (even though it’s running Trend Micro), as well as I tried the Win 7 machine with Trend Micro turned off and it still didn’t work, lead me to believe it’s not anti-virus related.

Darn, I was hoping that since something changed overnight it was the AV. Did Windows Defender turn itself on by mistake? Anything else running in the background? Onedrive, dropbox, etc? I can’t imagine anything like that would do this, but they’re easy enough to check.

Thanks once again for your response, Bill. I double-checked that Windows Defender was not running. I don’t use OneDrive so it’s not in the picture. Dropbox is running in the background but always has been when the apps all worked right. Just for sh*ts and giggles, I turned it off but to no avail. In looking at Task Manager, I don’t see anything running that isn’t normally running after the computer boots up. Again, for sh&ts and giggles, I used Task Manager to turn off everything that was non-essential … once again, to no avail. :disappointed:

The 260 character limit in the path of the DLL?

Are you sure you don’t rename a folder recently?

To avoid problems, I have my “Proyects” folder directly on the root, Also the “Windows App name” short to avoid the log names created by xojo for the builds.

… Yes

… No changes to folder structure or names

… I never considered that before now. But I think your suggestion is wise and I will immediately begin to transfer anything I have to the root. I suspect that since the suspect build folders did work when I copied them to the Desktop, that they will probably be issue-free when located on the root.

I’m surprised that more people haven’t reported running into that issue with long file names/paths. Of course, it still doesn’t explain what happened “overnight” … but at least it gets me back up and running again on the Win 7 machine which is more important at the moment than knowing the exact cause of the problem.

Thanks for taking the time to respond, Ivan!

I followed Ivan’s advice and after moving my projects to the root, all of them seem to be working fine. I think for sake of sanity, I’m not going to worry about “what happened overnight” … the answer must be that “the evil computer bug fairies came overnight and pooped on my build folders”.

1 Like
Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.