Another serious problem with Xojo relating to website

For the past few months whenever I go to the Xojo website it is in French. I live in England and I am using my own local IP address, through an extender. Google Chrome automatically translates this for me. How do I fix this? Is there any setting or is it just a bug? Thankfully this does not happen on the forum page. THANKS

You can change the language using the the drop down in the bottom right corner of the page. Odds are it was inadvertently changed at some point.