Android compiler not working on macOS Sonoma 14.0

After updating my macOS system to Sonoma, I’m encountering an issue where I can’t run any Android projects on a simulator. The simulator is running, but the app fails to start (with no error). Is this a widespread problem, or could it be related to a configuration issue? Does anybody have a similar problem?

Is there an updated version of Android Studio for Sonoma?

Sonoma is presenting many bugs, 14.1 was released to correct some. Forget 14.0

Also, seems people have workarounds (for Giraffe as I see)

https://www.reddit.com/r/MacOS/comments/16v8fjq/macos_sonoma_bugs_and_issues_megathread/

Updating Android Studio helped. Thanks a lot!

2 Likes

After updating Android Studio and macOS to Sonoma 14.1, the first try was successful - the app compiled and worked, but other attempts finished with failure. I’ve tried restarting my Macbook, running a project on Xojo Release 2023.3 then Xojo Release 2023.3.1, cleaning caches, RAM… Nothing helped until I made an absolutely simple thing - to delete the app from a simulator. And it works! Thanks for your help, guys.

1 Like

That happens quite often. I regularly wipe all data from emulators within Android studio.

1 Like