About Xojo and their latest release 2018r2

Okay, some thoughts about Xojo 2018r2. It is first release, which allows me to compile plain new project to 64bit. Earlier versions all crashed if I wanted to build 64bit release even with plain empty window. Good, I thought.

I still use Xojo 2014r3.2 in my projects as it starts about 40 seconds with all my bought plugins, instead almost four (!) minutes with newer versions of Xojo – with Xojo 2018r2 as well.

I thought that it’s time to move on and abandon 2014 year release, as there is one nasty TextArea StyledText RTFData bug, which takes RTF data in (probably), but not shows it. For workaround I used WinRTFDataMBS for storing RTF data to TextArea and it works, but… Every time I put data in this way to TextArea and then save it with StyledText-RTFData, after reloading font size increases by two points. This is not happens, when I save RTF data with WinRTFDataMBS instead of StyleText.RTFData, but when I use WinRTFDataMBS for invoking RTF data, Xojo IDE crashes. Not compiled program, it works nicely, but IDE crashes and you can think – is this way possible to work? No.

So I tried – in Xojo 2018r2 TextArea StyleText works as should be, but it’s many times slower to work generally and produces much large final result. My largest project compiled with 2014r3.2 is approximately 100 megabytes with all bells and whistles, but compiled with 2018r2 32bit weights more than 200 megabytes! Are you serious?

And now my problem. Tried to compile some of my smaller projects to 64bit and they compiled. It takes time, but they compiled and seems to work. But, but, but… With my largest project I get linking error:

[quote]Linking Executable
C:\Program Files\Xojo\Xojo 2018r2\Xojo Resources\Win32\lld.exe: error: C:\Users\Üllar\AppData\Local\Temp\xojo scratch 14952\VeeVärk.xojo_binary_project [F6B8DF4C]\Windows_x86_64\/#main.o: undefined symbol: _x_Püles.Püles.0017BA5F.109
C:\Program Files\Xojo\Xojo 2018r2\Xojo Resources\Win32\lld.exe: error: C:\Users\Üllar\AppData\Local\Temp\xojo scratch 14952\VeeVärk.xojo_binary_project [F6B8DF4C]\Windows_x86_64\/#main.o: undefined symbol: _x_kraan.kraan.0017BA6B.113[/quote]
And no – I can’t put it to FeedBack, as FeedBack did not work for me probably for some weird blocking reason(s) known only for Xojo smart team already for years.

I also include those two small pictures here. I removed them and placed pack. Still same error. When I removed them from project, it compiles 64bit and works. So any ideas? Same pictures works well, when compiled to 32bit…

64 bit builds seem to hate images that are not exactly multiples of 4 pixels wide.
(eg 100 = OK, 103 = bad or crash)
I have found this even on iOS work.

[quote=404820:@Jeff Tullin]64 bit builds seem to hate images that are not exactly multiples of 4 pixels wide.
Thanks Jeff, but this can be reason for one picture – püles - with dimensions 13x12, but second – kraan – is 24x24. Besides – I have lots of other pictures with dimension 13x12 in that project and they work well…

I noted in the past that methods with names that contain accented characters will cause a failure at the linking step. Perhaps this is something that you are experiencing. There are a few feedback requests on the topic. To my knowledge, this is still not fixed. Since there is a simple workaround (using non-accented characters), this bug may well wait a long time before it is fixed.

Thanks Louis, but again – I have plenty of pictures in that project with accented characters and they work fine. And as you can see – picture ‘kraan’ by 24x24 pixels did not consist any of accented characters…

Correct. Not all objects cause the accented character issue. Method and folder names do. Control names don’t. There are surely other issues and your’s may be completely unrelated to the accented character issue. It was an educated guess, since you regularly use accented characters.

This was the way people (in the USA) think in the 80s…

Time to evolve !

Do a simple test; set a, accented characters file name to images that works fine and follow what happens…

Hm – there is no sense at all. Removed ‘Püles.png’ and ‘kraan.png’ from project, renamed them to ‘Pyles.png’ and ‘krüün.png’ and added again, changed code where necessary and now it works. 8|
But mystery is still not solved as accented characters can’t be very guilty as I told earlier - I have lots of pictures with accented characters and now it will work with ‘krüün’ instead of 'kraan’…

And if be very honest – at first I tried and renamed that ‘Püles’ and made run. Linker then complained only about ‘kraan’. Then I renamed ‘kraan’ as told earlier to ‘krüün’ and voila – no linker complaints anymore.

Did you feed the Gremlins past midnight? You know that you should never do that.

Seriously now, as you say there is no logical explanation for this to change to fix the problem. Perhaps a file corruption fixed by the change? We may never know. I am glad that you resolved the issue. (and I am making a note to switch names around the next time something like this happens!)

:smiley: Computer world is strange and full of surprises – especially if Xojo is involved. I like Xojo as it is easy to use and gives quick results, but sometimes you must bend yourself whatever type of knot to achieve something that seems so obvious but not in Xojo logic. Fortunately problems are for solving and there are mostly quite many ways to do that.

But I don’t think that file corruption is involved, as 32bit executable linked well with both - 2014r3.2 and 2018r2.

I understand.

I had so many troubles with Xojo. Here’s a syntetic view of some:
I stopped to use external hard disk to store project I work with (excepted if I boot on it),
I stopped using non ASCII file names / Object names.

I had working project that worked fine. I saved it, shut down Xojo, the laptop.
Back home, and after lunch, Power on, run Xojo, load Project, run it: it does not works.

No, SkyNet is not behind that chimera. (it is on French TV, C8 and I am watching it while I write this text).

I forgot: crash also happens when the anti-piracy code executes…

and the Feedback (I naively sent because the IDE propose that to me) is hidden.

I have a Xojo licnese since 2013 (and some other licenses as far as REALbasic 1.0)