A PopupMenu disappears at window open time !

At design time, the PopupMenu is located at the left of the window (say 20,330) and I have a second onw located at 546,320.

At run time (IDE), the left PopupMenu disappears. Since I already had this while running on macOS (a different window, but based on the Windows * one).

So, while my MacBook was downloading High Sierra (was meant to do that), I fired my WIndows laptop and checked the project and saw what happens. (this does not happens while running the application on macOS.

In the IDE, Xojo 2017r2 (hey, I can run it, so I do it), I made a quest using the PopupMenu Control name and found no occurence in my project that is meant to change the PM_Templates (PopupMenu) location.
I also made a search for Win32 that failed too (no 64 Bits compilation here).

Now I am a bit short of suspect(s):
I downloaded Xojo 2017r2 before making the tests.
That trouble does not occurs when I run the project, execute that window on macOS.

Different matter, but I have templates folders (one for each OS), and they are not found (or not exists) while running on Windows 10 (last version), Xojo 2017r2.

At last, Xojo 2017r2 crashed and I stop any testing.

Clue(s) is/are welcome.


  • I started by building the Window design and code for running under Windows, then I duplicated that window, rename it macOS and adapt the code to the macOS environment (and then I do the same for Linux).

PS: what do the PopupMenu is not relevant in the context, but I checked its events.
Since this appears at window open time, I checked that wIndow Events (I had 3) without success too.

PPS: the WIndows 3in1 laptop small monitor (Full HD/1080p: 1920 x 1080) was hard to use (11,6" High DPI) and so is its keyboard / Mouse / TouchScreen (with Xojo).
Comparing to the macOS laptop screeen: 3360 x 2100 (13" Retina), the Script Editor part is … more generous.

I am unsure, but I think the Windows TouchScreen does not works with the Xojo 2017r2 IDE… Complementary checkings have to be done.

Did I understand correctly? A popup menu disappears on your windows machine during runtime? What version of windows are you running? Let me make a wild :wink: guess at Windows 7?

Sorry, wrong guess: Windows 10 (latest updates installed).

I was so… yesterday that I do not added two lines to modify its left and top values in MouseClick event (to display it correctly).

I will try that this afternoon.

Its not the problem I was thinking of then :slight_smile:

More sorry, then. :wink:

Thank you Julian.

At last, I found the reason why that PopupMenu disappears: it is a consequence of missing folders that holds platform specific data.

Because I did not run the project under Windows, I do not understand why the applciation was crying (not loud enough) about that missing folder (and an error in the text error message)…

I ran the applciation in WIndows XP (instead of WIndows 10 yesterday) / VirtaulBox, and I was able to better understand that trouble.

Now I have another one: some UI controls are not at the correct location and I do not understand why.

I will let that for tomorrow since it’s raining today and in these kind of weather, my eye vision is far from optimal (with glasses and sunny days it is not optimal, but far better)…

It’s sad to be an oldster…

Wrong: this was the solution for the Windows XP run, but not for the WIndows 10 test.

In the Windows 10 test, I used Xojo 2017r2 in the IDE and that was the reason why I had that trouble (the application does not found the supported folders even if they are beside the project file).

When back at home, I will load the Xojo version I have a license to build with and make the tests from there.

At first, I wanted to get an eye on the current Xojo version (2017r2) to watch differences in use vs my Xojo version (2015r1). Differences in the IDE, not specifically in the IDE running Application…

Back home.

Both 2015r1 AND 2017r2 are unable to run the project * ON WINDOWS 10 (last update).

On macOS (El Capitan 12.6), I am able to run the application from the IDE and get it running * with Xojo 2015r1 (and certainly also 2017r2; else I would remember and found a solution to run it).

I own only two (working, forget crashed computers) laptops that are nearly 3 years old (15 days left for the WIndows machine, nearly 4 months left for the Apple laptop).
I have the Desktop license for 3 platforms (three computers).

Regularly, I have to enter the license numbers. Actually, when I made the tests minutes ago on the WIndows 10 machine, I was unable to build the project. Usually, I do not really care, I simply re install the license #. But this is really insane…

A license to be run on three OS are not enough if you have only two computers ? Is it a joke ?
(in all cases, I do not laugh at all).
Suspicious Minds (Mark James) was singing the late Elvis Presley. I am starting to be very suspicious. Each time I had the bad idea to fire Xojo while Internet is ON, I got T.R.O.U.B.L.E.S. …

So, I will add a post build script to copy the needed data when building the application, but this will not change the platform differences…

BTW: I do not have tested recently that project on Linux… I think it is better to make the tests today ("cause the day is already bad…)

  • I build the project on macOS for all three platforms and run it in the IDE without trouble. Thus my surprise when running on the other platforms. (the data already existed on version 1 and I do not saw any trouble at all).

One wild guess: on the window open event, are you trying to restore a previous window position? Here is my thought process:

  • IDE has controls based on some location, say 20,330
  • IDE has window size bigger than that so controls are visible
  • Missing controls are locked to right size but not left side
  • Window open event resizes window enough smaller the controls move off left side of window, or behind another control

Just trying to come up with alternative explanations. Could even appear to be platform specific if only one environment had a saved window position small enough to trigger the reaction.

Hi Douglas,

thank you for your answer.

I stopped a 4 hours session and found that I nearly do not know what happens.

One suspect is the REALbasic.Rect, the only one that may move things.

I use it to place the windows to the Top/Right part of the screen. I am probably walking beside my shoes today and better stop here (just what I’ve done). And I have a development machine and a running machine; I finished to fire VirtualBox and use Windows XP for the testings. (My Xojo still compile for WIndows XP).

If I didn’t have diabetes, I would sing “Tequila” while drinking some… and maybe I would found the troubles earlier :wink:
But I cannot do that ! :frowning: