64bit build "Failed to execute linker : posix_spawn"

Following error appears when building my project:

Location : Linking Executable
Issue : Failed to execute linker : posix_spawn

IDE is Xojo 2018r2 running on macOS 10.13
Attempting to build for OS X 64bit with Optimization = Default

Any help how I can get this working is much appreciated.

Were you ever able to compile in 64-bit? Can you compile in 32-bit?

Have you tried clearing the cache? (Go to Preferences -> Building and use the Clear button. I recommend restarting the IDE after that just for kicks.)

Finally, could there be any permissions issues in either the Xojo directory or where your project is located?

Yes - I have long been building in 32bit for Windows and macOS with no problem.

Build for 64bit Windows is fine.

Build for 64bit macOS has never yet worked.

Regarding cache / permissions issues, I’ll double check to make sure.

I’ve had that a couple of weeks ago. Had to restart the computer.

I’ve tried restarting and clearing cache, unfortunately to no avail.

I can rule out any very obscure permissions issues because this occurs independently on both of the two macs I have so far tried. The build fails in the same way on both.

Missing files, or some other fault, in a build step?

I have now attempted the build on a brand new installation of macOS, and the issue persists. I suppose that this rules out permissions issues / missing files.

I removed all user-defined build steps before trying this to rule these out also.

Does anyone know if it is possible to get Xojo to be more descriptive with the error message? (some kind of ‘verbose’ mode, or debugging log mode)

If you want to send me the file privately, I’d by happy to help you troubleshoot. It’s going to be something simple, I think.

@Thomas Sanham - how much ram do you have?

16GB. Are you thinking that more physical ram might be necessary?

16 GB is plenty and that’s what I have here with no issues. Greg’s concern was more likely that you had far less, like 2 or 4 GB.

My error showed up after trying to run a tiny little project in 32bit. 20-30 locs (not klocs!).

Further investigation reveals large number of classes to be the problem

Xojo 2018r2 fails to build Mac 64-bit for a project with 1800 dummy classes each with a ten dummy methods (no code in any method)

Feedback case is 53286

Xojo 2018r2 fails to build the following project for macOS 64bit:


I’m seeing that too, but note that the project comes set to compile the Mac version as 32-bit. You must switch it to see the issue.

Kem - thank you very much for the confirmation.