2nd instance of my app loading with a "?" icon

IF I execute my app more than once, it opens up a new instance, as it should, but the icon displayed in the upper left corner of the window it’s a question mark instead of the app’s original icon…
(only tried in windows)
Why ?

thanks

You’re right. I never noticed it before. The icon referred to is the one at the left end of the window’s title bar. And it doesn’t seem to matter if the app has a custom icon or not.

I would guess that the app is trying to load that resource but can’t because it’s in use by the first instance. Sounds like a bug though.

feedback://showreport?report_id=48986

You don’t need to do anything special to the “Copy Sharing Link” output from Feedback :slight_smile:
(in fact, if you do, it messes it up for the forum)

feedback://showreport?report_id=48986

not seeing that here
an example that shows this would help

I added a sample project and image to the feedback report.

Thanks for follwing this up, Dale…

Doesn’t happen for me on any of the VMs I have for Windows (7, 8, 8.1) but those are all 32 bit
And Windows 10 vm which is 64 bit
(the ones from modern.ie)
And not on my real PC running Windows 7 Pro 64 bit

very weird

How can we help you, Norman ?

no idea since

  1. i’m not the windows framework engineer
  2. our windows engineer cant reproduce this
  3. nor can any of the rest of us

and we’ve tried a fair number of different builds of Windows 10 64 bit

Really weird.

I build the project and run it. I see the issue.
Copy the folder to my desktop and run it. The issue goes away. Hmmm

Ok it only happens when one of the parent folders is named Build [appname].xojo_binary_project.

Changing the folder name makes the problem go away.

cute

although I dont think I moved the app from the build dir

let me try this again to be sure

EDIT : WE HAVE A WINNER !!!
just remove the “.xojo_binary_project” extension on the BUILDS dir

and run

Windows never ceases to amaze me (and I literally mean it in the “wow I’m astonished” sense)