2021r1 web apps don't do anything?

I just got 2021r1 on Windows 7, and web apps simply do not run - in run from IDE they drop to “paused”, and when built they crash to “stopped working”. Same app worked just fine in 2020r2.1. Anyone experienced this issue?

Anyone having this problem? any web app run in the 2021r1 IDE stops at Sub Opening(args() as String)

Even tried a new project from scratch, example projects, nothing runs. 2020r21 was working fine.

There is no antivirus and no “Windows defender”. Built apps crash in “XojoConsoleFramework64.dll”


Open a feedback report for investigation. 21r1 has some problematic rough edges deserving a rounding dot release, and that can be one of those.

Worth checking that your browser is still one of the supported ones:

1 Like

The thing is, running web apps in the IDE does not work. It just pauses and does not resume. Sometimes launches the default browser (MS Edge), sometimes not. Debugging console and GUI apps works.

Tried under new OS user, destroy and reinstall, no good.

I think you missed the “it worked with 2020r2.1”, so 21r1 “possibly” broke it.

No, I didn’t miss it, the browser may not be supported for all we know.

What version of Edge?

1 Like

Edge 89.0.774.63

I’ll fire up a Windows 7 VM shortly and see if I have the same issue.

1 Like

The latest, since march 25. If this could break the XojoConsoleFramework64.dll on Win7, Chrome will do it too. I have not such issue on Win10. It doesn’t “look like” as a browser related issue.

I’ve made Firefox 87.0 (latest) the default browser - and voila, it works. Thanks to all for pointing in this direction!

Should probably be investigated, though.


It needs a feedback investigation due to: crashed XojoConsoleFramework64.dll on Win7 Xojo 2021r1, clean install, latest Edge browser (89.0.774.63). Works if switching to Firefox 87. Same test works without issues on 2020r2.1

Is the above summary correct? If so, please, file a bug report.

Absolutely correct!

feedback #64255

1 Like