2019R2 Drag hangs IDE and Apps in Yosemite

Has anyone tested the 2019R2 IDE or built-apps in MacOS Yosemite?

Both will hang with a wheel of death on a drag. For instance trying to drag from the IDE’s Library will immediately hang and must be force quit.

Same for dragging from a canvas-based control in a built-app.

I know this does not happen in Mojave.

It would be great for those with other OS’s to test this so we can figure out what the minimum OS for built-apps is.

Have not found a workaround but being that the IDE hangs too, hopes are not high.

Oh, I see that Emile’s ElCap post mentions the drag issue. So ElCap is scratched out.

Sierra? High Sierra?

High Sierra is definitively working.

maybe Xojo should just scratch 10.10 and 10.11 from their supported OS list unless they intend to fix this ?

I tried 2019R2 on my old laptop running El Capitan (10.11.6). I get as far as accepting the license agreement, then the IDE crashes and disappears. As mentioned above, perhaps the “requirements” page needs updating?

So I think we can rest assured, at this point, that only Yosemite and ElCap are affected by this bug.
I used the word bug, because I think it’s just that and Xojo 2019r2.1 will address this soon.
I’m not that concerned about Yosemite, but I would guess there are lots of ElCap installs still out there.

I had a strange idea: rename the Xojo folder inside the Library folder, then fire 2019r2 and drag and drop a PushButton from the Library: it crash too.

10.11.6 (15G22010)
MacBook Pro (Retina, 13 pouces, mi-2014
2,6 GHz Intel Core i5
8 Go 1600 MHz DDR3
Intel Iris 1536 Mo

Nota: the screen is set to 3360 x 2100.

For anybody who needs a quick and dirty bodge solution to this:

Use an older (working) version of the IDE, create a project with a window with all the controls you think you’ll need already placed on it, and then open this in 2019r2. Trying to drag from your “library” will still hang the IDE (at least, it does for me) but copy and paste works.

Yes I know, hardly ideal, and I haven’t tested what happens with dragging in a compiled app, but hey, it’s a start!

Better answer (also shared elsewhere):
double click in the Control you want in the Library, then place it where you want.

The crash feature is drag and drop, not adding a Control.

Or… (probably) wait for 19r2.1.

I have the same problem with 2019r2.
Attempting to drag a control to a window causes Xojo to hang.
This is on a MacBook Pro (15", mid 2010) with: 2.4GHz Intel Core i5; 8GB 1067 MHz DDR3; OSX 10.11.6 (El Capitan).
The previous version of Xojo, 2019r1.1, seems not to display the problem however.

I’ve read about fixes to 10.10/11 in 2019r2.1. I do expect it reaching enough maturity very soon and Xojo launching it. If people still find some rough edges after the release, I believe Xojo could launch a r2.2 just to round it before moving to r3 instead of keeping r2.0 creating problems and a bad impression that 2.1 already have solved it.

click twice in the icon of the control you want, then move it where you need it: this works.