2016r4 plugins issue

Why would 2016r4 ignore my plugins? I copied them over from the Plugins folder in 2016r3, but the app does not see them. Yes, I’ve tried re downloading the Xojo IDE, clearing caches, etc. to no avail. Any suggestions as to what else I can try?

Mac, 10.12?


you copied Xojo to the local disk?

Running from download folder will not work.

Sounds like you’ve been translocated.

Try removing the quarantine flag in Terminal

xattr -d com.apple.quarantine [drop Xojo.app here]

Rebooting into recovery mode and executing “csrutil disable” in the Terminal has saved our sanity on the development systems running 10.11 and 10.12.

For the sake of clarity: csrutil disable will disable System Integrity Protection.

(sorry I didn’t make that more clear :s ).

and disabling it should not be required or recommended.

Please understand that my comment was aimed at a development environment, not an end-user environment.

As a developer, the user of the system needs to do things that Apple may not “like” or “sanction”. SIP is a draconian lock and key that too limits the functionality of the system outside of normal user land use. Having been a Unix system user and sysadmin since the early 1980’s, I’m always surprised at the lengths that Apple will go to in order to do things that Unix already does?

So I guess we’ll just have to disagree on the usefulness of things like SIP, App-Nap and Grand Central Dispatch.

I already had SIP disabled. I tried the xattr -d com.apple.quarantine trick to no avail. Various folk and plugin developers have said that 2016r4 has issues. I’m going back to 2016r3 until r4.1 comes out.

It could very well be old plugins - not the IDE
They’re not immune to changes in frameworks (like moving to hidpi) etc

I have been experimenting. It would seem that no plugins in the Plugins folder are being recognized by the IDE, not even Xojo database plugins.

The weird thing is, I moved back to 2016r3 and now the same thing is happening there. It was working perfectly this morning. Damn.

Any suggestions? I’ve tried everything I can think of: deleting caches, Disk Utility first aid (no problems), rebooting, disabling SIP, etc.

Really, this sounds like being relocated.
That means that OS X internally handles your app as if it were in another folder to prevent some kinds of dylib hacks.
Xojo in that mode can’t find the plugins folder.

You need to copy it first to another location and Finder should remove the Quarantine flags.

Thanks Christian. I copied the folder to the desktop, applied

sudo xattr -d com.apple.quarantine

to the Xojo app and copied it back. All is now well.

One of my old MBS plugins will no longer work in Xojo > 2016r1. Clobbers all plugins in the process. Took a bit of time finding the culprit.

Sigh. That would be useful info if you had actually stated which plugin was the culprit.

Sorry @Markus Winter, I was in a hurry when I posted. The plugin is MBS Overlay Plugin from 3 years ago. I might add that the current version of this plugin works fine. Also special thanks to @Björn Eiriksson for helping me out with suggestions in finding the problem, which I initially thought was one of his plugins that was causing my plugin woes

I use the MBS Overlay plugin to counteract the issue of excessive flicker in Windows apps. I take an overlay opaque snapshot of my window, do any data modifications (ListBox control in my case) underneath, then fade the window out over 200ms which displays a nice fading transition with no flicker.

That is cute :slight_smile: