2016R1 AppCrash?

Hi there. I have a project that compiles & runs fine on OSX and Win7 / 8 / 10. If I build it with 2016R1, the App crashes on Windows - no real “error message” except:

Problemereignisname: APPCRASH
Anwendungsname: Gruppe 3.exe
Anwendungszeitstempel: 56fe9807
Fehlermodulname: XojoGUIFramework32.DLL
Fehlermodulzeitstempel: 56fe99fd
Ausnahmecode: c00000fd
Ausnahmeoffset: 001ac0f7
Betriebsystemversion: 6.1.7601.
Gebietsschema-ID: 1031
Zusatzinformation 1: e5e9
Zusatzinformation 2: e5e96225bad787014438bb953804b306
Zusatzinformation 3: 71ad
Zusatzinformation 4: 71ad178da1ea97f00cad648a087be7be

If I run remotely from my Mac - the debugger does not kick in. If I take the very same project and build it with 2015R41 - works fine. I use some MBS plugins and the cubeSQL plugin. I have tested on Win7 64bit AND Win7 32Bit - build it 32Bit only.

Any ideas?

Thank you,


2016r1 also crashed repeatedly on my Mac–maybe 6 times in about 2 hours. So, I went back to 2015r4 for now as 2016r1 seems very unstable, at least on Macs.

We use 2016r1 in complex projects all day on macs- please file a Feedback report with your project/crash report if you can. It could be plugin related or something else, and we’d like to help.

In this case Jan is reporting that the built App crashes.
BTW: I see the same but only on 1 of a dozend machines. Also on a German Windows 7 32Bit Machine.

It’s a bit embarrassing if you have to tell your User you don’t have a clue whats happening :wink:

Sadly, it’s a machine i am not allowed to take any information from, to put in a Feedback… :frowning:

In all fairness users can do some pretty crazy things and blame it on the developer :wink:

[quote=258170:@Sascha S]
It’s a bit embarrassing if you have to tell your User you don’t have a clue whats happening ;)[/quote]

That is why I mostly program for myself - my user (me) is sympathetic most of the time, as we are both confused much of the time. :wink:

Nawwwwww :stuck_out_tongue:

In this case, most Machines are Setup the same (Dell Machines, Corporate Image Restore, User can’t even change the Date/Time, …). My App is one of very few installed Apps. :slight_smile:

Identical machines ? I’d be skeptical
I’ve had exactly this experience with “identical” machines from HP and they are “the same spec wise” but that’s where “identical” stopped.
So the corporate image had to have multiple drivers for CD/DVD drives, different 3.5" drivers, different on board video, ethernet adapters and even USB interfaces.
It was awesome
And lord knows if one of those affects your app

Travis, I’ll try. Unfortunately I’ll need time for this. And we want to go live with a major update or our in-House-App next week. Maybe I’ll find the time to test more & file a crash report over the weekend (developer’s “free time”).


Yeah like ‘upgrading’ to 10.11 El Capitan!

I’ve even had one customer write and tell me, he wished he’d not upgraded as our isn’t the only app that he uses which no longer works.

Ok. It’s NOT the plugins. It’s the encrypt / decrypt routine (that worked fine for ages on Win & Mac) in order to hide registering keys for MBS plugins & DynaPDF Plugin.

I tracked it down to: Xojo.Crypto.RSAGenerateKeyPair - this simply crashes on Win7 32 Bit (with installed VC_redist_x86.exe). Same thing on Win 10 32 Bit. Feedback creation is underway done. Case No 43399.


Linkified <https://xojo.com/issue/43399>