2014r2 IDE slowing down

I noticed an annoying problem with 2014r2.
After some time I’m working on it it starts becoming incredibly slow. This is true for every task, from editing code to compiling.
I don’t really understand what causes this, but it seems happening when working with more than one open project and/or two workspaces.

Needless to say, the same doesn’t happen with 2014r1.1
(OS X 10.9.4)

Someone else noticed this behavior?

[quote=110402:@Massimo Valle]I noticed an annoying problem with 2014r2.
After some time I’m working on it it starts becoming incredibly slow. This is true for every task, from editing code to compiling.
I don’t really understand what causes this, but it seems happening when working with more than one open project and/or two workspaces.

Needless to say, the same doesn’t happen with 2014r1.1
(OS X 10.9.4)

Someone else noticed this behavior?[/quote]

Yes, I have the noticed the same slowness after using IDE in long sessions. But I had this issue with 2014r1.1 too. I’m coding in my mac air 8GB of RAM vs 16 of my desktop computers and the laptop slows downs more often.

I am using also Cocoa MBS plugins, if that could help to fix this issue.

When this happens, take a sample of the IDE process in Activity Monitor and create a new Feedback case with the sample attached.

I have noticed that R2 didn’t seem to address very many of the IDE issues… cursor still goes where it wants, so you end up typing in the code area instead of adding a parameter list… etc.

IDE still has the issue when every time you do a build it eats RAM. On a smallish project my Xojo RAM usage is over 1.8GB and continues to creep up. If you have multiple instances of Xojo open then it gets even worse. I am running on Windows 8.1 with 16GB Ram and an 8GB virtual RAM (on an SSD drive) and after about 5 hours I have to exit Xojo r2 and restart as it just becomes like treacle.

Good to know. That discards OSX IDE only issues.

Pardon my ignorance. What steps should we do to send you feedback information? This bug is driving me nuts when I have to code +12 hours a day. Will do all I can to help you reproduce and fix this bug, but I am unsure how to proceed.

Open Activity Monitor
Select the IDE process in the list
Press “Sample process”
It can create a file for this
Attach that file to a new bug report

Norman - how would I do the equivalent in Windows? Is it “create dump file”?

I’m not aware that there is an equivalent
You can try WinDbg https://forum.xojo.com/13723-project-no-longer-working-with-rb2014r2-windows-but-worked-fine/p1#p109765

If you go into the task manager and right click a process, there is a create dump file option. But I wouldn’t know if that was of any use to anyone there or not.

Windows dumps aren’t nearly as useful as the OS X ones but they still have value.

Noticed same thing here, after 4-5 hours it sloooows way down. After 6-7 hours it pretty much locks up. 8GB RAM, Win 8.1.

Thanks Joe, I will surely do it.

Happened again this morning and here it’s a Feeback case with sample attached: feedback://showreport?report_id=34447

The sample looks absolutely normal and like what the IDE should be doing. You should start the sample in Activity Monitor and then switch back immediately to the IDE to make it exhibit the slow behavior.

Just attached to the ticket a sample while typing in the code editor which was incredibly slow.