2014r2.1 IDE Crashes on Windows 7

I have been doing all my development on my iMac and got everything working and mac version released.
I then open project on Windows 7 and if I run the app in the debugger… the IDE goes “Not Responding” every single time.

Are there logs somewhere that tell me what is causing it?
Could it be a memory issue? i.e. not enough memory

I’m on Windows 7 Home Premium SP 1 with AMD FX Eight Core Processor and 16 GB of memory. 1TB hard drive.

You seem to have plenty of memory.

on Windows 7, look in the system event log ( either type eventvwr in the “execute” box, or Click the Start button, Click Control Panel, Click System and Maintenance, Click Administrative Tools, Double-click Event Viewer)

You can also look for Microsoft Sysinternals on the web. The tool collection contains a utility called dbgview, which can be very useful in tracing issues such as your’s.

OK I have eventvwr open but where should I look? LOTS of options there.

I poked around after I restarted and looked at Application logs:

Fault bucket 89127930, type 22
Response: Not available
Cab Id: 94665476000

Problem signature:
P1: Xojo.exe
P3: 6.1.7601.2.1.0

Attached files:

These files may be available here:

Analysis symbol:
Rechecking for solution: 0
Report Id: 5367bf4f-e7d4-11e6-a81b-74d43597bdc8
Report Status: 8

Oddly this time after it sat for 4 or 5 minutes the “Not Responding” went away and I was able to “Stop Debugging” without the IDE crashing.

If I watch the xojo.exe process its memory footprint keeps growing while the “not responding” is happening… my guess is there is some memory leak in this old version. The above process data also uses the word “LEAK” in it as well. ???

Does it happen on a simple app, or just that one particular project? Does the project run if you compile it?

I restarted computer and it has not been happening on main project.
Maybe it was some sort of memory issue.

YES project runs fine as a compiled app on Windows.

I just tested a very small example project and that worked fine too.


It started crashing again and I found this in eventvwr -> Windows Logs -> APplications

Faulting application name: Xojo.exe, version:, time stamp: 0x53da569a
Faulting module name: RBGUIFramework.dll, version:, time stamp: 0x53da561c
Exception code: 0xc0000005
Fault offset: 0x00064978
Faulting process id: 0xc6c
Faulting application start time: 0x01d27bfb9a7c3552
Faulting application path: C:\Program Files (x86)\Xojo\Xojo 2014r2.1\Xojo.exe
Faulting module path: C:\Program Files (x86)\Xojo\Xojo 2014r2.1\Xojo Libs\RBGUIFramework.dll
Report Id: 4eac71fc-e824-11e6-a81b-74d43597bdc8

Does it do this same thing if you use the Remote Debugger and run from your mac?

OK not sure what you mean. The IDE never crashes on the Mac. Just Windows.
I know nothing about the “remote debugger”… how does that work?

Look in the extras folder. You’ll want the desktop version for Windows. You take that little app over to your windows machine and run it. In the ide, you run “remotely” to the other machine. Basically it builds, zips, transfers, unzips and then runs over the network.


So I keep developing on my Mac where my IDE is never crashing… but use the remote debugger to run and test the Windows version… sending it to my Windows machine to run there.

Yes. Even if it’s just to help us isolate the problem.