10.6 oder 10.7?

Ist es richtig, dass mit Xojo 2013 Release 4.1 erstellte OSX - Carbon - Anwendungen erst ab 10.7 laufen, also nicht mehr unter 10.6?
In den UserGuide-Fundamentals ist noch 10.6 angegeben!

Probier’s mal aus. Ich dachte 10.7 ist für Cocoa.

Schau nach dem Kompilieren mal nach, welcher Wert bei “LSMinimumSystemVersion” in der Datei “/Contents/Info.plist” deines fertig kompilierten Programmes drin steht.

Die Frage ist nicht, was da bei dem Wert in der plist steht, sondern was passiert, wenn man das auf 10.6 ndert. Aber Carbon und 10.6 sind eh obsolet.

Sagt man das uns beiden nicht auch nach? :stuck_out_tongue_winking_eye:

Ich mag SnowLeo wesentlich mehr als Lion/ML/Mavericks.

@Markus: haha…. da hast Du wahrscheinlich recht.

Ja, Snow Leopard war wirklich die beste der Mac OS Versionen. Aber zumindest mit Cocoa unter RB2011r4 hatte ich einiges an sehr merkwürdigen Crashes. Das hat für Xojo bestimmt keiner gefixt.

Nun, ich scheine eine der wenigen Ausnahmen zu sein. Kein Mac OS war bisher so performant auf meinem 2009er Mac Pro wie Mavericks. Wenn man sich die Apple-Foren anschaut, hat das aber wohl keine Allgemeingültigkeit.