10.10.3

After updating OSX to 10.10.3, after each boot from OSX, the Xojo IDE or any other Xojo App hangs in the first program execution, after force quitting and restarting the app or the Xojo IDE, everything goes back to normal.

I’m the only one?

Crash log:

Date/Time: 2015-04-11 21:31:24 +0200
OS Version: 10.10.3 (Build 14D131)
Architecture: x86_64
Report Version: 21

Command: Xojo
Path: /Applications/Xojo 2015 Release 1/Xojo.app/Contents/MacOS/Xojo
Version: 2015.1.0.0 (15.1.0.3.28976)
Parent: launchd [1]
PID: 361

Event: hang
Duration: 1.00s (process was unresponsive for 124 seconds before sampling)
Steps: 11 (100ms sampling interval)

Hardware model: iMac9,1
Active cpus: 2

Fan speed: 800 rpm


Timeline format: stacks are sorted chronologically
Use -i and -heavy to re-report with count sorting

Heaviest stack for the main thread of the target process:
11 start + 53 (Xojo + 44175562) [0x2a220ca]
11 main + 36 (Xojo + 6436) [0x2924]
11 _Main + 257 (Xojo + 47776) [0xcaa0]
11 REALbasic._RuntimeRun + 34 (Xojo + 1994166) [0x1e7db6]
11 ??? ( + 1411148) [0x304e84c]
11 ??? ( + 1417911) [0x30502b7]
11 ??? [0x9470077c]
11 ??? ( + 210543) [0x2f2966f]
11 ??? ( + 1417786) [0x305023a]
11 Application._CallFunctionWithExceptionHandling%%op + 248 (Xojo + 612452) [0x96864]
11 Delegate.Invoke%% + 34 (Xojo + 48152) [0xcc18]
11 ??? ( + 210758) [0x2f29746]
11 ??? ( + 210656) [0x2f296e0]
11 ??? [0x9470bdc5]
11 ??? [0x9470cff3]
11 ??? [0x94717138]
11 ??? [0x94717448]
11 ??? [0x9c114224]
11 ??? [0x91537901]
11 ??? [0x91657c34]
11 ??? [0x9c133053]
11 ??? ( + 203472) [0x2f27ad0]
11 ??? ( + 209016) [0x2f29078]
11 ??? ( + 1417786) [0x305023a]
11 Application._CallFunctionWithExceptionHandling%%op + 248 (Xojo + 612452) [0x96864]
11 Delegate.Invoke%% + 34 (Xojo + 48152) [0xcc18]
11 ??? ( + 207783) [0x2f28ba7]
11 ??? [0x9368668d]
11 ??? [0x936b8952]
11 ??? [0x9c14a6f4]
11 ??? [0x9c14a8ff]
11 ??? [0x9c14adb7]
11 ??? [0x929c4119]
11 ??? [0x9471350a]
11 ??? [0x94713c28]
11 ??? [0x94713d7c]
11 ??? [0x94713e01]
11 ??? [0x94716344]
11 ??? [0x94716072]
11 ??? [0x94716726]
11 ??? [0x9471691d]
11 ??? ( + 203553) [0x2f27b21]
11 IDEApp.Event_NewDocument%%o + 493 (Xojo + 2977929) [0x2d8089]
11 Commands.Dispatch%%s + 122 (Xojo + 8320352) [0x7f0560]
11 Commands.Dispatch%%o<Commands.Command> + 2933 (Xojo + 8319371) [0x7f018b]
11 IDEApp.HandleCommand%b%oo<Commands.Command> + 4697 (Xojo + 3089911) [0x2f35f7]
11 TemplatesWindowNew.TemplatesWindowNew.Present%%o<TemplatesWindowNew.TemplatesWindowNew>oo + 302 (Xojo + 29351737) [0x1bfef39]
11 Window.ShowModal%%o + 42 (Xojo + 92379) [0x178db]
11 ??? ( + 1415685) [0x304fa05]
11 ??? ( + 1417840) [0x3050270]
11 ??? ( + 207439) [0x2f28a4f]
11 ??? ( + 210656) [0x2f296e0]
11 ??? [0x9470bdc5]
11 ??? [0x9470c721]
11 ??? [0x96e0342c]
11 ??? [0x96e03631]
11 ??? [0x96e038f8]
11 ??? [0x9159e90b]
11 ??? [0x9159eaa6]
11 ??? [0x9159f531]
11 ??? [0x9166354f]
11 ??? [0x915e7ab4]
11 ??? [0x915e8006]
11 ??? [0x915e86e6]
11 ??? [0x94ea3fb3]
11 ??? [0x94a9c2b9]
11 ??? [0x94a5858a]
11 ??? [0x94a4fe74]
11 ??? [0x94deb56d]
11 ??? [0x94f31c28]
11 ??? [0x94f31d18]
11 ??? [0x94f1b2e5]
11 ??? [0x91abc0db]
11 ??? [0x91a4e679]
11 ??? [0x91a4e737]
11 ??? [0x91a5e9f5]
11 ??? [0x9156e5a9]
11 ??? [0x9156e672]
11 ??? [0x9156e6c1]
11 ??? [0x91a5f47b]
11 ??? [0x91ad46cc]
11 ??? [0x91a666b0]
11 ??? [0x93687c65]
11 ??? [0x936b760e]
11 ??? [0x95a159ce]
*11 hndl_mach_scall + 216 (kernel + 2314568) [0xffffff8000435148]
*11 mach_call_munger + 373 (kernel + 2109413) [0xffffff8000402fe5]
*11 mach_msg_overwrite_trap + 205 (kernel + 1200925) [0xffffff800032531d]
*11 ipc_kmsg_send + 743 (kernel + 1133495) [0xffffff8000314bb7]
*11 ipc_mqueue_send + 529 (kernel + 1147857) [0xffffff80003183d1]
*11 thread_block_reason + 175 (kernel + 1319343) [0xffffff80003421af]
*11 ??? (kernel + 1329236) [0xffffff8000344854]
*11 machine_switch_context + 367 (

I have no problems with 10.10.3 running Xojo 2014r2.1

Use Disk Utility to repair the permissions and check for any disk errors.

Rename your Examples folder.

If i rename the Example Folder, go, but if i load after a project hangs. I’ve noticed whenever a window is shown, and has a listbox with rows, the app hangs after a OSX boot. If the app has no Listbox, or the listbox have no rows then no hangs.
Xojo 2014 r3.2 the same, only Realstudio 2012 works, before i update to 10.10.3 there are no problems.
I have done everything like permissions, disk errors… Combo Update 10.10.3 ecc.
This behavior has the Xojo IDE and any other Xojo compiled App.

Start Activity Monitor
Then start the IDE
Switch back to Activity monitor & sample the IDE
And post the sample gathered to a bug report