FYI - Xojo Does Not Open or Run on Apple Silicon Mac Developer Transition Kit Hardware

  1. 4 days ago

    Perry F

    Jun 29 Testers
    Edited 4 days ago

    I received my Developer Transition Kit Mac Mini today. I've spent the afternoon testing my Xojo apps and many other applications, and all seem to be running just fine. However, Xojo itself does not open. It bounces for awhile and then becomes unresponsive. I think the translation process that is supposed to allow Rosetta 2 to convert x86 apps does not seem to function with Xojo.

    I will do some further testing to see if I can get it to come up and report back, but I wanted to give you guys a heads up.

    Do you have any DTK hardware available to test and get Xojo running on A-chips? Would be curious to hear your thoughts on this. I've been watching the blog but haven't seen any news or details posted regarding the Apple Silicon chip transition with Xojo.

    if I can be of any help with testing, just let me know.

  2. Geoff P

    Jun 29 Xojo Inc Austin, Texas

    Our kits are on their way and we are already doing what work can be done without them. There could be many reasons why Xojo isn't running for you but it's my understanding that others with DTKs have run it. All of this is quite early as well so I'm sure there will be many more betas of Big Sur on Apple Silicon before any new hardware ships.

  3. Perry F

    Jun 29 Testers

    Excellent, glad you guys will have the hardware as well. Interesting that others have got it working. I'm still not having any luck, but will see what happens in the next few weeks/months. Thanks for the update!

  4. Greg O

    Jun 29 Xojo Inc scout.galaxy.barn

    @Perry F - What version of Xojo are you using?

  5. Perry F

    Jun 29 Testers
    Edited 4 days ago

    2019 Release 1.1

    I haven't been able to move to the newer versions, I have some fairly large projects and I haven't been able to get them to compile with the new Xojo stuff.

    I'm downloading the latest version of Xojo now though to see if that will open. Will report back shortly.

    UPDATE - just tried the newest version, Xojo 2019 Release 3.1. Does not appear to open either, it bounces for awhile and then stops and just says "Application Not Responding." I've let it sit for about 15 minutes in that state with no luck.

  6. Emile S

    Jun 29 Europe (France, Strasbourg)

    Open Xojo without any project first.

  7. Norman P

    Jun 29 Testers, Xojo Pro outside admiring the sunshine,...

    maybe open activity monitor & sample it ?

  8. Christian S

    Jun 30 Testers, Xojo Pro, XDC Speakers, Third Party Store Germany

    I tried Xojo 2019r3. You can wait >15 minutes with 100% CPU usage and nothing happens.
    I bet the Rosetta translator is busy, but translating the IDE may be too complex.

  9. Thom M

    Jun 30 Greater Hartford Area, CT

    I tried with 2019r3.1 and my experience was the same as Christian's. My apps would run fine, the remote debugger stub would run fine, but the IDE would not. I tried a sample, but couldn't make heads or tails of what it was doing. I don't think it's Rosetta translating though, as Xojo code was being called. But it looks like it just kind of died in the event loop. I never got a splash screen.

  10. 3 days ago

    Perry F

    Jun 30 Testers

    This is the same thing happening to me. It never fully opens, no splash screen, no IDE. I've only tried opening it from the application icon, not trying to open any projects.

  11. Valdemar D

    Jun 30 Testers, Xojo Pro Europe ( France, Paris )

    Has someone test with actual beta 2020 r1 ?

  12. Perry F

    Jun 30 Testers

    I just tested, does not work with 2020 R1 pre release either, same result.

  13. Christian S

    Jun 30 Testers, Xojo Pro, XDC Speakers, Third Party Store Germany

    I wrote a test app in Xcode and the test app can load all 500 plugin dylibs just fine.
    Works both in Intel and ARM Mode.

    I just wonder where Rosetta stores the cached translated files.

or Sign Up to reply!