HiDPI/Retina Problems

  1. 6 days ago

    erin j

    Jun 27 Testers, Xojo Pro

    Any idea why an app runs beautify on a retina screen (Mac OS 10.15.5) running in the debugger but then is out of focus as an actual build? It is not simply the image assets, but everything: labels, buttons, listboxes, etc. All of the do not seem to be supporting HiDPI when built.

  2. Beatrix W

    Jun 27 Testers, Third Party Store Europe (Germany)

    Screenshots? Are you doing something to your plist file?

  3. Jeff T

    Jun 27 Midlands of England, Europe

    If you use App Wrapper, check the 'Info' tab
    Look for 'Supports Retina' and ensure that has a value of '1'

  4. 5 days ago

    erin j

    Jun 28 Testers, Xojo Pro
    Edited 5 days ago

    I do not use app wrapper.
    There is no editing of any plists happening.

    It is very confusing.

    Here is in the debugger (Pic [/img]):
    -image-

    Here is as a build (Pic ):
    -image-

  5. Jeff T

    Jun 28 Midlands of England, Europe

    Use 'Get Info' on your deployed app.
    Does it have 'open in Low resolution' ticked?

  6. erin j

    Jun 28 Testers, Xojo Pro

    It is checked and it is also greyed out... So, I can not uncheck it.

  7. erin j

    Jun 28 Testers, Xojo Pro

    I am compiling in Xojo 2019 1.1 by the way, and yes "supports HiDPI" is checked.

  8. Jeremie L

    Jun 28 Testers, Xojo Pro, XDC Speakers, MVP Europe (France) - packr.app

    From the Apple High Resolution guidelines:

    Apps that aren’t Cocoa apps have this checkbox selected and unavailable (dimmed)

    https://developer.apple.com/library/archive/documentation/GraphicsAnimation/Conceptual/HighResolutionOSX/Explained/Explained.html#//apple_ref/doc/uid/TP40012302-CH4-SW1

    There must be something that makes the OS think your app isn't a Cocoa app.
    Do you have any #if not DebugBuild code in your app?

  9. Sam R

    Jun 28 Testers, Xojo Pro, Third Party Store Hengchun, Pingtung, Taiwan

    @erin j It is checked and it is also greyed out... So, I can not uncheck it.

    Try a different computer, this is a setting that's local to your computer. I do not know where it is stored, so I don't know how to undo it.

    Actually, there is something you can check.

    1. Make sure your built application is running.
    2. Download my App Report (https://ohanaware.com/appreport/ ).
    3. Open App Report.
    4. Select your application in the sidebar.
    5. Select "Info.plist" from the View menu, and look for NSHighResolutionCapable in the list.
    6. Select "Preferences" from the view menu and also look for "NSHighResolutionCapable" in that list.
    7. Select "Extra Attributes" from the view menu and see if there's anything there.

    If you'd like me to take a look, click on the Share button, select send as e-mail, then send it to support at ohanaware.com.

  10. erin j

    Jun 29 Testers, Xojo Pro

    I have looked at the plist manually and the proper flags are there.
    That said, @Sam R you are on the right track. It has to do with the machine. I too do not/could not figure out where the OS was storing the flag. But removing the application entirely from the machine and doing a fresh install fixed it. The problem was that the auto update (over writing files) was not removing the OS flag for customers.

    Thank you for your help.

or Sign Up to reply!