Copy,Cut and paste

  1. 2 weeks ago

    I detected this:

    In a method

    • select some code and copy (command-c) (say A)
    • then paste it (command-v) (A is pasted)

    thats work ok

    Then select some other code and Cut it (command-x) (say it as B)
    then paste it, command-v, you get A not B

    And if you are not very aware you put wrong code in the method.

    As anyone experimented this?
    I've a 30" video of the process, how may I post it?

  2. -image-

  3. Emile S

    Jun 27 Europe (France, Strasbourg)

    Adding the OS, Xojo, etc. versions usually help…

  4. The Xojo version is seen in the video 3.1
    Mojave 10.14.6
    This only happens on Xojo.

  5. Emile S

    Jun 27 Europe (France, Strasbourg)
    Edited 2 weeks ago

    This is the link:

    "https://www.dropbox.com/s/idbjach95pxggre/Cut.mov?raw=1"

    Copy / Paste it.

    I saw nothing, but this is just me. I will watch a second time.

    Have-you tried after a boot as guest or in an external hard disk ?

    Have-you tried to quit, shut down, boot and run Xojo only (no other running application) ?

    Is it with all projects or only with this one ?

  6. Alberto D

    Jun 27 Testers, Xojo Pro Austin, Texas
    Edited 2 weeks ago

    Link to video

    Working correctly here, Xojo2019r3.1 and Mojave 10.14.6

  7. I'had two Xojo projects opened, and it happened only in one of them. (I tried the same copy&cut&paste) in both.
    Reseting the computer, opening the two Xojo projects again , and doing the same… now it work normal
    So, never will know what happen.
    At least I learned how to post a video.

  8. Emile S

    Jun 27 Europe (France, Strasbourg)

    @Enric H At least I learned how to post a video.

    No, you don't/was not able to do that in this forum.

    To get the link I had to search it in the html code of this page…

  9. But… I put the link << https://www.dropbox.com/s/idbjach95pxggre/Cut.mov?raw=1 >> in the post…
    as I do with images…

  10. Alberto D

    Jun 27 Testers, Xojo Pro Austin, Texas
    Edited 2 weeks ago

    @Emile S No, you don't/was not able to do that in this forum.

    To get the link I had to search it in the html code of this page…

    You don't need to search in the html code, you can right-click the broken image and select copy image address:
    -image-
    the URL that you get is:

    https://www.dropbox.com/s/idbjach95pxggre/Cut.mov?raw=1

    you just need to post the code and change raw=1 to raw=0 in the end

    https://www.dropbox.com/s/idbjach95pxggre/Cut.mov?raw=0

    and you get this:
    https://www.dropbox.com/s/idbjach95pxggre/Cut.mov?raw=0
    if you use the insert 'link' from the forum, you can do this:

    [url=https://www.dropbox.com/s/idbjach95pxggre/Cut.mov?raw=0]Link to video[/url]

    to get this:
    Link to video

  11. Thanks all
    Is it correct now?
    link video

  12. Alberto D

    Jun 27 Testers, Xojo Pro Austin, Texas

    @Enric H Thanks all
    Is it correct now?
    link video

    Yes

  13. Emile S

    Jun 27 Europe (France, Strasbourg)

    @Alberto D you can right-click the broken image

    There was no broken image. Only “-image-” is displayed.

    But I do not care, I get the URL (searching for -image-) and that is the important part.

  14. Tim P

    Jun 27 Testers, Xojo Pro Rochester, NY

    @Emile S There was no broken image. Only “-image-” is displayed.

    That text is what you right-click on. This is the Firefox equivalent:
    -image-

  15. Alberto D

    Jun 27 Testers, Xojo Pro Austin, Texas
    Edited 2 weeks ago

    Different browsers different behavior. Just trying to help and make things easier to find. Sorry my message was interpreted as "right click the broken image icon", as Tim pointed out, you just need to click anywhere over the broken image (icon or text).

    BTW: Safari displays the video in the forum without issues.
    -image-

or Sign Up to reply!