Compiled App crashes on one system but not build system

  1. 6 days ago

    So I have a custom app that I am using for my business and it compiles fine, runs fine from the binary on the development system but when I deploy to the business system it crashes without any error messages. How do I get a crash message generated? All I am able to get is a Segmentation Fault (core dumped) error when I run the app from the CLI.

  2. Philip C

    Jun 27 Testers, Xojo Pro Cooroy, QLD, Australia

    I had a similar problem. Worked fine on smack but died on windows under VMWare.
    It turned out that I was running out of memory because I fucnt close windows - suggest looking at Bratrjce’s article on using test instruments

  3. 5 days ago

    Javier M

    Jun 28 Xojo Inc, Testers, Xojo Pro, XDC Speakers, Third Party Store AprendeXojo - Europe, Spain

    Hi @Ian M

    May it be because the crashing Linux lacks some of the required libraries? (also, check if you're compiling for 64 bit and the problematic Linux distribution is also 64 bits…or 32 bits).

    You can check for the required libraries on deployed systems for Linux at https://docs.xojo.com/Resources:System_Requirements

  4. brian f

    Jun 28 Testers, Xojo Pro California

    As @Javier Meacute;ndez suggested check required libraries

    In a terminal use ldd while launching the application and see what that outputs

  5. Yeah, starting with -ldd didn't reveal anything more than a Segmentation Fault (core dump). I thought about the libraries too...

  6. Tim J

    Jun 28 Testers, Xojo Pro N. Phoenix, AZ

    Are you calling out to printer settings?

  7. 4 days ago

    No on the printer. I do have plans to add a "Gift Certificate" report but that's on the back burner for now.

or Sign Up to reply!