"Run" no longer working after first "run" on Windows

  1. 5 days ago

    Hi all,

    Since a few weeks, I come across an error (related to Malwarebytes) which is harming Xojo, especially prospective users.

    When I choose "Run" the first time, the application runs smoothly. However thereafter, not a single "run" works. I see the application compiling but there it stops. Quitting and starting Xojo has no effect, "run" doesn't work any longer.

    When I choose a new empty project, it runs fine the first time. Then it is not working any more. Then you think loading the original project again, no working "run". Also using an older version Xojo 2017 v3 will make no difference.

    In task manager, everything is gone when Xojo is quit. The only thing which helps is a restart of the computer. I am using a Fujitsu-Siemens Esprimo Mobile D9515 with Windows 7, 6GB of RAM and internal SSD with Xojo 2019 v3. Everything else works fine, except Xojo.

    However, I found the cause of this problem... MalwareBytes. It seems that the latest version of Malwarebytes is blocking... Xojo runtimes. Sad, but true!

    There is no reason to block Xojo and applications like Malwarebytes should detect and recognize that.

    I need to know in which directory those debug runs are saved so I can exclude that directory. Can you please, tell me where I can find that directory?

    Thank you so much in advance. Have a great day!

    Chris

    Do you get any logging in malwarebytes to tell you what it's done to stop the further runs? This may help in finding out if malware is blocking something to do with xojo or the running exe

    The default build folder for unsaved projects is under "Edit>Options>Building>Build unsaved apps in". If you've saved the app it'll build in a sub-folder at the saved location.

    A quick scan using Process Monitor is also showing access at C:\Users\username\AppData\Local\Temp\

    If you're able to, I'd try and whitelist all exe's in your xojo install folder rather than picking at specific folders.

    The main windows exe folders will be (if you are using 2019r3.1 in its default install location)

    C:\Program Files\Xojo\Xojo 2019r3.1\
    C:\Program Files\Xojo\Xojo 2019r3.1\Xojo Resources\Win32\
    C:\Program Files\Xojo\Xojo 2019r3.1\Xojo Resources\Frameworks\
    C:\Program Files\Xojo\Xojo 2019r3.1\Xojo Resources\Frameworks\HTMLViewer\

  2. Louis D

    May 22 Testers, Xojo Pro QC, Canada

    You can go into malwarebytes parameters and list as safe the folders where your application code resides. Debug and build folders are by default underneath this folder, unless you changed the defaults in Xojo. (in my case, D:\SoftwareDev. I have subfolders for each application under this root.) You could whitelist each subfolder. I did not need to go that far.

    I did this once several years ago and forgot all about it since. I also had to list a few libraries that I inistalled separately. Xojo plugins should not be an issue as they are brought into the debug or build folders, whitelisted in the first step.

  3. 4 days ago

    Emile S

    May 22 Europe (France, Strasbourg)

    I think I read something about Windows 7 deprecated (being unsupported this year), but not sure ?

    So an OS update may be a good idea.

    Also, using the last Xojo - if you use API2 - may be a good idea in these troubled times.

    Of course, IMHO.

  4. Julian S

    May 22 Xojo Pro Answer UK

    Do you get any logging in malwarebytes to tell you what it's done to stop the further runs? This may help in finding out if malware is blocking something to do with xojo or the running exe

    The default build folder for unsaved projects is under "Edit>Options>Building>Build unsaved apps in". If you've saved the app it'll build in a sub-folder at the saved location.

    A quick scan using Process Monitor is also showing access at C:\Users\username\AppData\Local\Temp\

    If you're able to, I'd try and whitelist all exe's in your xojo install folder rather than picking at specific folders.

    The main windows exe folders will be (if you are using 2019r3.1 in its default install location)

    C:\Program Files\Xojo\Xojo 2019r3.1\
    C:\Program Files\Xojo\Xojo 2019r3.1\Xojo Resources\Win32\
    C:\Program Files\Xojo\Xojo 2019r3.1\Xojo Resources\Frameworks\
    C:\Program Files\Xojo\Xojo 2019r3.1\Xojo Resources\Frameworks\HTMLViewer\

  5. Thank you all for your advice and help which is much appreciated. I tried to exclude the "build" directory but the problem still persisted. After that, I excluded the whole directory in which Xojo was installed and now everything is working normally again.

    Thank you all for putting me on the right track again, what should I do without the help of this community?

    Have a great day and stay safe!

    Chris

or Sign Up to reply!