Strange Editor Error

  1. 8 weeks ago

    Tomas J

    Apr 1 Testers, Xojo Pro Europe (Germany)
    Edited 8 weeks ago

    Today I've run in to a strange IDE error:

    I've typed these lines in my Editor and Compiler thew out syntax errors:

    // Sanitation
    if szCmdLine.left(7) = "http://" then szCmdLine = szCmdLine.right(szCmdLine.Length-7)
    if szCmdLine.left(8) = "https://" then szCmdLine = szCmdLine.right(szCmdLine.Length-8)
    if szCmdLine.right(1) = "/" then szCmdLine = szCmdLine.left(szCmdLine.Length-1)

    -image-

    This is not possible, szCmdLine is a String, 100% for sure. But when using the AutoCompletion in the Editor with pressing Tab and clicking on the Suggestions explicitly, the syntax error messages disapperead. But there is no change in code at all excpet that .lenght is now .Lenght

    -image-

    What I am missing? Can anybody verify this?
    Bug?

    (latest Xojo on fullpatched macOS Majave)

  2. brian f

    Apr 1 Testers, Xojo Pro Chilly California

    You are saying that when you compile "Length" changes to "Lenght"?

  3. Tomas J

    Apr 1 Testers, Xojo Pro Europe (Germany)
    Edited 8 weeks ago

    Arggg.... finally.... I am stupid :-)
    Okay I leave this here and do not delete it as best example for stupidity or at least how small typos cause pain in a developers life :-)

  4. brian f

    Apr 1 Testers, Xojo Pro Chilly California

    We all do this :)
    We are here to help each other out

  5. Tomas J

    Apr 1 Testers, Xojo Pro Europe (Germany)
    Edited 8 weeks ago

    the old .len was much shorter and less magnetic for typing errors ;-)

  6. Hector M

    Apr 1 Testers, Xojo Pro
    Edited 8 weeks ago

    The one that gets me all the time is typing contEiner instead of contAiner :)

or Sign Up to reply!