Building for Earlier iOS Versions

  1. 3 days ago

    Bob G

    Mar 25 Pre-Release Testers, Xojo Pro Minneapolis

    With Xcode 11 and Xojo 2019.3 it seems I can only create apps that run on iOS 13.

    The Xojo docs indicate I should be able to make apps that run on iOS 10 - 13.

    What is needed to do this?

    Thank you.

  2. Dave S

    Mar 25 San Diego, California USA

    I don't know what Xojo is doing to enforce such restrictions, but I do know with Xcode/Swift sometimes I can create apps that will run all the way back to iOS9.3, but for the most part (iOS specific features not withstanding).... iOS10 is the minimum

  3. Bob G

    Mar 25 Pre-Release Testers, Xojo Pro Minneapolis

    Dave,

    But at the moment I can only create apps that run on iOS 13. I also would like to support 12.

    Do I need some different things from Apple?

  4. Gavin S

    Mar 25 Pre-Release Testers, Xojo Pro, Forum Moderators, MVP UK

    @Bob G But at the moment I can only create apps that run on iOS 13.

    Xojo can run iOS apps pre-iOS 13 in the iOS Simulator but you need to download a Simulator for each OS. This is done in Xcode > Preferences > Components (see screenshot below).

    -image-

  5. Art G

    Mar 25 Prescott AZ

    I'm running the app I'm working on now in both 12.2 and 13 in the simulator.

or Sign Up to reply!