No Taskbar

  1. 2 weeks ago

    I created an app years ago in Realbasic.
    It controls our robotic arm "RoboArm" that we sell to grade schools.

    It was set to use the whole screen - so the Menubar and Taskbar were both hidden.

    This was fine until I recently rewrote it with the xojo 2019 3.1 ( that was a daunting task with all the deprecated items I had to work out!

    I just found out that Avast blacklisted my program because it hides the Taskbar and it won't come back on when the program is exited.
    They of course tried it without a robot hooked up so apparently it did not exit properly, but that is a separate issue.

    We have decided it would be better to leave the taskbar on. However, I cannot find out how to do it!
    I have read several posts and have turned on the Menubar on every window as well as set the Menubar visible button.
    I even put "MM.MenuBar.Visible = True " in the open event of the Main window which has been renamed MM.
    I read one post that said he renamed his back to Window1 and that worked for him. It didn't for me!
    This is on Win10. The TaskBar shows up on the Mac!

    Any other ideas?

  2. Christian S

    Mar 19 Pre-Release Testers, Xojo Pro, XDC Speakers, Third Party Store Germany
    Edited 2 weeks ago

    Fullscreen property in use?

    See
    http://docs.xojo.com/Window.FullScreen

  3. Alberto D

    Mar 19 Pre-Release Testers, Xojo Pro Austin, Texas

    Select your window go to the inspector and check under Menus if you have Menu Bar - None.
    -image-

    For Windows you need to specify a MenuBar.

    From: https://docs.xojo.com/MenuBar

    On macOS, if a window does not have a MenuBar specified, then the window uses the MenuBar specified on Application.MenuBar.

    On Windows and Linux, if a window does not have a MenuBar specified, then the window will display without a MenuBar even if one is specified in Application.MenuBar.

    I hope this is what you are looking for, I got confused with TaskBar and MenuBar (English is not my first language).

  4. Wayne G

    Mar 19 Pre-Release Testers, Xojo Pro, MVP Auckland, New Zealand

    On the window in the inspector click on the gear icon to show advanced settings, then under deprecated you'll see Menu Bar Visible. Set this to on.

  5. Christian - All windows have the Fullscreen button set to off. I just tried setting the main window to on, but it didn't change.
    Alberto - All Windows have Menu Bar set to MenuBar1.

    I just noticed the the menu bar shows "File" and "Edit" but it doesn't show any of the buttons on the right.
    Maybe a display resolution type problem?

  6. Alberto D

    Mar 19 Pre-Release Testers, Xojo Pro Austin, Texas

    Create a different menu, assign main window to that menu and see if anything changes.

  7. Julian S

    Mar 19 Pre-Release Testers, Xojo Pro UK

    I think you missed Wayne's post, here's a video of where to look

    https://www.dropbox.com/s/pcdv9t01x4xkq4j/2020-03-19_23-08-30.mp4?dl=0

  8. I created a new menu and deleted the old one. Assigned all windows to it. Nothing changed - still no taskbar.
    Julian - The Menubar visible option is turned on for all windows.

    None of the windows are showing the taskbar at the bottom. Nor are they showing the minimize, maximize, and close buttons at the top right. They do show the menubar.

  9. Julian S

    Mar 20 Pre-Release Testers, Xojo Pro UK

    What is the "Frame>Type" of the window?
    Do you have any declares in your project that could be turning off the taskbar?

  10. It is a Document window as are the 3 other main windows. I have a couple of moveable modal windows and one plain box.

    I don't use any Declares.

  11. I found Window.SystemUIVisible in the docs, but the program doesn't recognize it! I tried to put it in the app.open and window1.open events.

  12. Ok, I found something. I had to put " aWindow.FullScreen = False" statement in the open event of each of the windows.
    Except now some of them are not full screen and not all the objects are showing.
    At least the main window shows the full menubar and the taskbar.

  13. Why is it that sometimes it doesn't recognize the statement while you are typing it in. I had to type in "window1." then hit the Tab and select "Fullscreen" from the menu. And it didn't recognize the Window.SystemUIVisible at all.

  14. Julian S

    Mar 20 Pre-Release Testers, Xojo Pro UK

    Window.SystemUIVisible seems to be bugged hasn't been implemented/is missing

    I've added a ticket about it Feedback Case #59482

or Sign Up to reply!